Unable to login to bestbuy.com

Description of the issue: Unable to login to bestbuy.com with error “Sorry, something went wrong. Please try again.”
How can this issue be reproduced?

  1. Go to bestbuy.com
  2. Click Sign In
  3. Sign in with email and password

Expected result: Log in

Brave Version( check About Brave): 1.1.23

Additional Information: console gives “Unhandled promise rejection TypeError: Failed to execute ‘fetch’ on ‘Window’: Value is not a valid ByteString.”

I was able to login into bestbuy on macos and win10 vm using the latest brave @ Version 1.2.43 Chromium: 79.0.3945.130 (Official Build) (64-bit)

updated to 1.2.43 on mac without luck

Try “Allow all cookies” in Shields. But I was also able to login and logout (standard login) to bestbuy

Have you tried in a private window? If it works in a private window then you possibly have failing extension…

Just tried with private window. No luck same error.

Hrrmmm… Did you try @fanboynz 's suggestion?

Also, for my curiosity, can you post a screenshot of the extensions you use so I can maybe install them on my end and play with them? just go to brave://extensions/ and screenshot it…

Also, is your locale in the US?

I’ve disabled brave shield completely but no luck.
As for extension I have 1Password X – Password Manager, EditThisCookie and Proxy SwitchyOmega. I think I installed all of them from Chrome store. My locale is Chinese

I don’t think it’s the extensions, but can you disable all of them and see if it works? I know we did a private window but I don’t know if you allowed your extensions to run in private… The only other thing maybe the locale? When you access bestbuy are you in in china or the US?

I’m in US but the locale is set to Chinese. I just tried to set it to English without success.

I think you need to add language then configure the language to be displayed in brave… But I don’t know if that helps you any… I tried doing simplified chinese and the only time it was in chinese was for brave… ie preferences, etc. Going to websites was still in engilsh for me… I didn’t want to change in locale in windows since I really can’t read chinese and wouldn’t be able to change things back…

Maybe changing the brave language and the langage of bestbuy.com to english is something you can try to do? Sorry, I have no ideas at all from here…

I must have misunderstand your previous question. The website is in English and I’m in the US. Brave’s display language is Chinese.

I tried to add English and set it as display language but as you can see in the screenshot it’s displaying an empty box

Oh… so I just tested tah then and was still able to login… The only suggestion I might have then is disabling all you extensions and try logging in… clear the site content and try logging in…

Tried both with hard reloading no luck

I guess one mre thing you can try is to make a new profile and see if that works… @Mattches you have any ideas?

@drjisper,
I’m also observing some strange behavior on bestbuy.com. In the last 5 minutes of testing I was:

  • Unable to login unless Shields were down
  • Unable to reset password when Shields were down
  • After clearing all site data and resetting site permissions, with Shields up, I now can’t log out ???

This will require some further digging – I appreciate your patience.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.