Unable to install Brave Browser on Linux Zorin OS

Below command is what I used to download what I think is the latest version per the Brave website:

wget https://brave-browser-apt-release.s3.brave.com/pool/main/b/brave-browser/brave-browser_1.18.75_amd64.deb

lsb_release -a = provides below output:

Distributor ID: Zorin
Description: Zorin OS 12.4
Release: 12
Codename: xenial

inxi -F = provides below output:

System: Host: ************** Kernel: 4.15.0-128-generic i686 (32 bit) Desktop: Xfce 4.12.3
Distro: Zorin 12 xenial
Machine: System: Hewlett-Packard (portable) product: HP 2000 Notebook PC v: 0686120000204A10000620100
Mobo: Hewlett-Packard model: 3577 v: 24.49 Bios: Hewlett-Packard v: F.47 date: 12/17/2011
CPU: Dual core AMD E-450 APU with Radeon HD Graphics (-MCP-) cache: 1024 KB
clock speeds: max: 1650 MHz 1: 916 MHz 2: 826 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6320]
Display Server: X.Org 1.19.6 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1366x768@59.99hz
GLX Renderer: AMD PALM (DRM 2.50.0 / 4.15.0-128-generic, LLVM 6.0.0) GLX Version: 3.0 Mesa 18.0.5
Audio: Card Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.15.0-128-generic
Network: Card-1: Realtek RTL810xE PCI Express Fast Ethernet controller driver: r8169
IF: eno1 state: down mac: ac:16:2d:5e:88:41
Card-2: Broadcom and subsidiaries BCM4313 802.11bgn Wireless Network Adapter driver: wl
IF: wlo1 state: dormant mac: 08:ed:b9:13:ce:26
Drives: HDD Total Size: 500.1GB (1.5% used) ID-1: /dev/sda model: ST9500325AS size: 500.1GB
Partition: ID-1: / size: 457G used: 6.0G (2%) fs: ext4 dev: /dev/dm-1
ID-2: /boot size: 720M used: 206M (31%) fs: ext2 dev: /dev/sda1
ID-3: swap-1 size: 1.02GB used: 0.00GB (0%) fs: swap dev: /dev/dm-3
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 55.0C mobo: N/A gpu: 56.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 200 Uptime: 1:06 Memory: 546.8/3570.7MB Client: Shell (bash) inxi: 2.2.35

I downloaded and installed the GDebi Package installer for my system and tried installing it that way but GDebi stated that it was the incorrect architeture. Please advise which am I supposed to download instead. Thanks!!

Hello @cyberoptiq

did you tried to run those command

Please re-read my post…particularly the last part at the bottom…but yes I did in case you didn’t…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.