Unable to generate wallet in Beta release

Description of the issue: Unable to generate a new wallet in fresh install of Brave Beta. I hit “Create Wallet” then it will continually say “Try Again”.

Steps to Reproduce (add as many as necessary): 1. 2. 3. Anywhere you go to create a new wallet is where the problem shows itself

Actual Result (gifs and screenshots are welcome!): Uploaded above

Expected result: That it creates a new wallet

Reproduces how often: Consistently every time. I’ve restarted the browser multiple times making sure it’s not running in the background also and it still happens.

Brave Version(See the About Brave page in the main menu):
Version 1.12.89
Chromium: 84.0.4147.89
Windows 10 Version 10.0.18363.836

Reproducible on current live release (yes/no): no. Weirdly enough I could create a wallet on both Nightly and the current version of brave. Just not beta

Additional Information:

So I had reset the wallet on the nightly build and tried generating a new wallet and got the same error. I’m starting to wonder if the network that i’m on recently put blocks to some of Braves services? Anyone know of a way I can check this theory?