Unable to connect uphold wallet in android brave browser

Well Brave support W T F are you doing to fix this issue!

same here, never get an error just cycles back after logging into uphold

Having the same problem. Hope to see a reply here soon from the dev team for a fix.

They are busy trying to repair their reputation.

I figured out the issue, for some of you this will work. It Did for me. Others may be facing a different problem.

  1. Open your Uphold wallet
  2. Click the more tab on the bottom right
  3. Click Settings
  4. Click the profile section
  5. Click the giant verify wallet banner

I had to submit my drivers license and a photo (Canadian regulations I believe). Then it said I was verified.

I then went to the brave mobile browser again, clicked the triangle and tried the verify wallet thing again. This time, it said ‘wallet verified’ and gave me 9 notifications of BATs being added to my uphold wallet.

I think this particular issue could be resolved by brave by informing people to open the uphold app and verify the wallet there, since that’s what they mean.

1 Like

Seems like we are conflating a lot of issues here.

If you are seeing the “device limit reached” message
This means you have linked the maximum number of devices to your Uphold/Gemini account that we allow at this time. Please see the following post for information on how to submit a wallet unlinking request:

If you are stuck in a wallet verification loop
If you go to Verify wallet and run through the Rewards verification process, complete it, and receive no errors/error messages, but your Rewards page/panel still shows Verify wallet, you’re likely stuck in a verification loop. This can happen when Uphold can’t communicate with the browser due to blocked cookies. For this, try logging into Uphold.com, opening your Shields panel and changing the cookie control setting to Allow all cookies, then try the verification process again.

If you are seeing a wallet verification error
I believe this could be due to a couple things:

  1. Your wallet is in a corrupted state, in which case you will likely need to reset your wallet. You can tell if your wallet is corrupted by going to brave://rewards-internals and checking to see if there is a Wallet payment ID on the General info tab. If there is not, your wallet is likely corrupted.
  2. You have not completed Uphold’s KYC requirements.
  3. Your wallet has been flagged.

If you believe you fall under case 1 or 2 above, please send me a DM and I will do my best to assist you. For #2 above, simply complete the KYC requirements in your Uphold account and you should be good to go.


Thanks for all the answers. However, here is my problem

My wallet is created on 25 April 2021

I tried connecting to uphold , it gave me drive limit reached. I tried connecting to another uphold wallet , it said uphold wallet mismatched.

How can I fix it?

I raised ticket to remove two of my wallet ids which I don’t recognise , waiting for it to be removed

I have only one Brave nightly verified wallet on my PC , , I have on phone brave and Brave beta, and after update software I loose linked wallet.
when I go to brave://rewards-internals general info, I have there more than one browser werified, how to unlkin them . what to do?

Thank you Mattches, for the info. I submitted the request for the account removals. Im wondering typically how long those requests go? After having dealt with it for months and not checking the forums (my fault) I’m now excited to finally get it fixed. Thanks!

This has been more than 2 months since this issue appeared after Android 12 update.
On Android 12 mobile app of Brave, I just can’t connect/verify the wallet using Uphold login! It just doesn’t connect at all. Totally frustrating!!
When is Brave gonna solve this problem?

@tek007 See the response above from Matches. There’s a couple steps to take to figure out why and then to take depending on what’s causing it.

I’m waiting in having the previous browsers removed so that I can add my new phone. This is definitely something that we should have account control access to ourselves. Process improvement!

Thank you for the thorough description, it have helped me a lot. I realized that I have the “device limit reached” issue due to switching phones. I’ve used your description to extract all relevant details and I have used the linked form to create a support ticket, although after creating the ticket, I did not receive any e-mail confirmation regarding the ticket. Is this normal, or should I try to create the ticket again?

ps: For me this message only shows up on the rewards-internals page in the event log, unfortunately when I’m trying to connect my wallet it does not inform me why it cannot be connected, just goes back to the original rewards pop-up, no error message or anything, like nothing has happened. Would be nice to have this error message displayed somewhere so it’s easier to understand what is happening.

Unfortunately this still has not allowed me to connect.

unable to connect my uphold wallet in android brave browser !
i have tried it going to internals page , everything is good there
what to do?
i don’t have more devices link to uphold account

Did you get resolution with these steps shaman?

Yes, I did, they have replied to my wallet unlinking request, which I’ve filled on the above provided link. They have informed me that in a future release they are planning to remove the device limit.

Quick recap of what I did:

  • I’ve checked the rewards-internals page on my new phone, where I’ve seen on the Event logs page, that the reason I cannot connect to my wallet is that I’ve reached the device limit.
  • Done the steps in Mattches’ answer to extract the required information (Custodian Member ID, and wallet IDs of the devices that I’d like to keep) and filled the unlinking request form from the same post.
  • It took some time but eventually I1ve received an email that they’ve unlinked it. After that I could connect my wallet on the new phone normally.

Hope this helps.

Where is link to submit request to unlink devices


The new UI for the Rewards splash screen had me hoping this was fixed. Any updates on this issue as to when it will get fixed?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.