Unable to connect Brave browser with Uphold wallet

Dear All

I’m not able to integrate my Brave Browser with Uphold Wallet as it shows region not supported (screenshot attached), but previously I had integrated the both seamlessly via the website, and then i installed the browser again but was unable to connect it to Uphold wallet.
After chatting with Uphold customer care they advised to contact Brave support as everything was alright from their side.

Kindly advise.
Thanks and regards