Unable to claim rewards (4 months now)

For more than 4 months now, I haven’t been able to claim any rewards. There are 4 pending “claim rewards” buttons, and whenever I solve the capcha on any of them, all I get is:

" Oops, something is wrong. Please try again later.

Brave Rewards is having an issue. Please try again later."

I have recently migrated my profile to another system, and the problem persists. Restarting obviously did nothing, as well as creating a new profile. None of the posts I have searched for came to a meaningful conclusion.

1 Like

Same problem here … good luck. :slight_smile:

Are you using a VPN connection of some kind? Do you have any extensions installed in the browser at this time?

A handful, yes. Among them Browsec VPN and uBlock Origin. I tried to disable all my extensions, restarted the browser and tried again, no changes.

Can you check and ensure that your window is zoomed in a the default 100% level when performing the capcha?

I can confirm that it is at 100% zoom, yes. I still get the “Oops, something is wrong” message.

1 Like

I have experienced this issue multiple times. I am also experiencing an issue on the desktop browser whereby there is no response to clicking on the claim button, with no captcha. When hovering my cursor, it looks as though the button is clickable.

From the looks of threads on this forum, this has been an ongoing issue for over a year, with no resolution. I don’t think I’ve ever been able to hit claim and have it work first try. I’ve been using brave for close to a year now.

Has anyone found a real fix?

Is there any way that I can get effective help on this? I could not find any eMail or online help system in place. The forum doesn’t seem to work.

(go here…) (Having issues uploading rewards to brave wallet)


Well, not sure what happened, but 2 of my 4 unclaimable rewards have vanished today, but I got a boost in BAT. I can not say if it’s in the amount of the rewards or not, but I guess that is something, at least.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.