Unable to access Citrix Workspace App

I need to access an application for work that is accessed by Citrix Workspace App. It works fine with Chrome and Firefox but not Brave.

Replication:
Unfortunately, because I work in healthcare, I have to log in to a secure site with login/pw prior to getting the error message that “You cannot log in at this time.” Please close your browser to protect your account." So, I don’t know how someone outside the company would access it without my working with them (happy to do so, however).

Expectation:
Access of an electronic health record (EHR) system via Citrix, accessed via Brave.

Version 1.41.96 Chromium: 103.0.5060.114 (Official Build) (x86_64)

iMac 2019, MacOS 12.4.

I appreciate the help.

@Toraken

To be clear . . .

You have the Citrix Worspace App installed as an Extension to Brave Browser (v.1.41.96), on your Mac (MacOS 12.4).

CORRECTED: You have the Citrix Worspace App installed as an application (NOT an extension to Brave Browser) on your Mac (MacOS 12.4).

You need that Citrix Workspace App, in order to make a Citrix connection to a remote computer at work.

On that work computer, there is an ‘electronic health record (EHR) system’ application, that you need to use.

According to Citrix documentation at:

NOTE:

There are two ways to access Citrix Workspace.

One is through the natively installed Citrix Workspace app, which replaces Citrix Receiver for simple, secure access to Citrix Cloud services and workspaces.

The other way to access Citrix Workspace is through a browser with the Workspace URL. The Workspace URL is enabled by default, usually in the format:

https://yourcompanyname.cloud.com

Thus, with, or without, using the Citrix Workspace App, the Citrix process will try to make ‘secure access to Citrix Cloud services and workspaces’.

More Citrix documentation: Configure access to workspaces

An important EXCERPT:

Remote subscribers can gain external access to their workspaces if you configure external connectivity with Citrix Gateway or the Citrix Gateway service.

For information on enabling remote access to workspaces, see External connectivity in this article.

External connectivity

Basically, authentication for you, that would allow you to connect to the computer at work, needs to be enabled at work.

Because you are able to access your remote worksite by using Chrome and Firefox, we assume that authentication for you, is enabled; and, Brave Browser should also be able to access your worksite.

So, I am guessing, that one of the possible problems for Brave Browser, is going to, and thru, the Citrix Cloud.

When visiting: ‘https://www.citrix.com’, set the site-specific Shields (Lion icon - near right end of URL address field) settings:

  • Shields: UP for this site
  • Trackers & ads blocked (Aggressive)
  • Cross-site cookies blocked
  • Fingerprinting blocked (Strict)

In a Brave Browser > New Window, go to: brave://settings/shields

  • Disable: Auto-redirect AMP pages (AMP - Google’s Accelerated Mobile Page)
  • Disable: Prevent sites from fingerprinting me based on my language preferences
  • Trackers & ads blocking: Aggressive
  • Enable: Upgrade connections to HTTPS (HTTPS EVERYWHERE toggle switch)
  • Enable: Block scripts
  • Block fingerprinting (aka Fingerprinting blocking): Strict, may break sites
  • Block cookies (aka Cookie blocking): Only cross-site

Next, go to: brave://flags

  • Disable: Enable De-AMP - requires Relaunching Brave Browser

Next, go to: brave://settings/security

IF you did not Enable: HTTPS EVERYWHERE in the GLOBAL SHIELDS settings, above, then you may want to . . .

  • Disable: Always use secure connections (HTTPS ONLY toggle switch)

Note, while at: brave://settings/security you might also:

  • Disable: Use secure DNS

Next, go to: brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter [*.]citrix.com as the site . . . but Do Not Enable:

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for the following entry:

  • https://cloud.citrix.com

Next, go to brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter [*.]citrix.com as the site . . . but Do Not Enable:

  • Current Private session only

Click the Add button

Repeat those steps for the following entry:

  • https://cloud.citrix.com

Try your connection to work. If not successful, then return to: brave://settings/shields and set:

  • Block fingerprinting (aka Fingerprinting blocking): Standard

Try your connection to work. If not successful, then return to: brave://settings/shields and set:

  • Trackers & ads blocking: Standard

Try your connection to work. If not successful, then return to: brave://settings/shields and set:

  • Block fingerprinting (aka Fingerprinting blocking): Disabled

Thanks for the fantastic detail you provided.

I tried everything you recommended, to no avail.

When I use Citrix Workspace App with Firefox, it’s not an extension within Firefox. Citrix is just downloaded on my Mac and it’s accessed that way.

Thanks again for your help.

Not sure what’s changed but I’m now able to access the application from Brave. @289wk, thanks for your extensive help!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.