Unable to access 1password from Activites/Share menu on iOS

ios
#1

Description of the issue:
I’m unable to access 1password from the Activities/Share menu running iOS 12.1.4 and latest Brave browser (1.8).

Steps to Reproduce (add as many as necessary):

  1. Visit a page that 1password has credentials for logging in to.
  2. Select the little up-arrow from a box share menu item in upper right-hand corner of the browser next to the Lion icon.
  3. Notice there is no 1password option (even if you select the “…” “more” options… it’s not listed.

Actual Result (gifs and screenshots are welcome!):

Expected result:
I’d expect to see 1password as an option as it is in Chrome and other browsers.

Reproduces how often:
100%

Brave Version(about:brave):
1.8

Mobile Device details

Android/iOS Version
12.1.4

Additional Information:

0 Likes

closed #2

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes

opened #3
0 Likes

#4

Thank you for reporting, @jvaleski. Apologies for this having not received a response earlier. I’ll message our iOS team now and see if this needs to be promoted to a proper issue on GitHub.

0 Likes

#5

Hey @jvaleski,

As of iOS 12, password auto-fill is built into the keyboard, so we no longer bundle the 1Password extension with the app.

You can enable iOS-wide Password Auto-Fill if you haven’t already in the Settings app under Passwords & Accounts > AutoFill Passwords and make sure 1Password is checked on.

Then when you browse in Brave, you simply focus on a login field and tap the “Passwords” button at the top of the keyboard to bring up 1Password.

0 Likes

#6

right. however (and maybe the bug description should change?) when you use external (bluetooth) keyboards on iPads with iOS 12+ Password autofill is not an option for any browser other than Safari. so, I’d like to see this fixed :).

I would note that Chrome on iOS leaves extension in there (presumably for precisely this reason).

And yes… this ultimately feels like a bad design choice/bug with iOS, but the workaround seems pretty straightforward (e.g. browsers continue providing the option for Share menu invocation).

0 Likes

#7

Ah, I see. Thanks for the heads up :slight_smile:

We’re taking a better look at this, as you’re right, it should be showing up.

Edit: Issue logged: https://github.com/brave/brave-ios/issues/948

0 Likes

#8

this guy does a better job explaining it… https://www.mylearning.be/2018/06/password-autofill-on-ios-with-external-keyboard/

0 Likes