Uh oh! The Brave Rewards server is not responding. We will fix this as soon as possible plzz help

Can you try reconnect your Uphold account via BAT triangle icon at URL bar?

Yes, but it loads up my uphold account instead of connecting it and when I exit that it still shows the error message in reward page as in the image above.

what should i do now?

Just to make sure, you disconnect and reconnect your Uphold account right?

@eljuno
I was never able to fix the same issue

Same here - how do you get around this issue?

@Zavi @mme @OttoSan sorry for the inconvenience, servers appear fine so this could be some kind of bug affecting you. Would any of you have time for a screen share with one of the engineers to diagnose?

Same problem here, since a long time, I don’t have any VPN turned ON, I tried to reconnect my Uphold, nothing happened, cleared my cache too

Yes , I just changed my uphold account’s password which resulted in disconnecting the brave wallet and then when I tried connect it , it started showing this message.

how am i suppose to ?

And when i try to verify it again it shows this

But still Brave wallet shows this -

Same issue facing as well

Yes - on what platform?

is there nothing to fix this?

@eljuno please fix this or at least respond!!!

@Zavi apologies for late response. I’m AFK for the past days. Can you get in touch with Jimmy? :point_up:

My workaround mentioned above is works for most cases. Since it happened to me too.

How can i contact him?

@eljuno how can i contact him ?

Hi @Zavi can you DM me?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.