Udemy Login issue

So, I encountered an issue where you can not log in to another site via Google or Facebook. I guess it’s the issue with inbuild ad blocker, at first I thought shield was blocking the pop up (I turned it off), but shield is not the problem here. What I think, inbuilt ad blocker is also blocking genuine popups. The Gif was not working, so click on this to watch video.

Try allowing all cookies for Udemy.com from shields. Since you are trying to login to the site using a 3rd party authentication all cookies should be allowed. This should most likely fix the issue. Let me know if it works

Read again, I said I turned the shield off and tried again.

There’s no need to be rude in your responses. I did read your message but you never mentioned you disabled shields you just said about adblocker thats the reason i asked you to try enabling all cookies and check.

Which version of brave are you using? If you are on muon there won’t be any popup shown. Please upgrade to the new brave-browser.

Please use the template while filling out details which avoids asking questions back and forth. The more details you add the better we can troubleshoot the issue.

1 Like

I am not being rude. I’d still ask to read again. BTW I’m on v0.56.15

To login into Udemy, I had to login using chrome and then import cookies into Brave.

Works for me. Can you try clearing the browser cache once and try? I don’t see anything wrong on the developer console as well. The page could be trying to load from a cached version.

Do you have any other google login in any of the tabs? If so can you try closing them and then try logging in using Google authentication?

1 Like

I tried again, the pop is coming out now but again it’s not logging in via google. Hence I had to import cookies from chrome.

For login you need to enable all cookies. 3rd party cookies are blocked on Udemy by default shields settings. Here’s what you can do

  1. Close all tab except settings
  2. Clear browsing history (all settings in the popup)
  3. Open a new tab, visit Udemy.com
  4. Click shields, set cookie to Allow all cookies
  5. Login using Google Authentication

This should fix it. Let me know if it works with the above steps

1 Like

:point_up: This is the process I’ve used successfully in the past when I was unable to authenticate with Google. Additionally, I was able to reconfigure Shields to my desired settings after I authenticated in and could (can) now authenticate without having to drop protections.

1 Like

TBH, I don’t have to manually allow cookies when the shield is turned off.

Well, my work is done anyways.

Brave is amazing browser, I love it but it has lots of compatibility issues. I hope more people will contribute to make improvements.


Glad the issue is resolved. Its still a work in progress so we will fix all these issues eventually. Its a learning curve for us as well to see what breaks and what works out of the box.

Once we have site shields exceptions UI implemented it should work with ease.

Closing the thread for now. Please open a new thread if you have any other issues.