Ubuntu installation - "Please make sure the webpack devserver is running"


#1

Hi! I installed Brave in the suggested apt install way on Ubuntu 16. Now when I launch it (/usr/share/brave/brave or via Dash) it just fills the screen with a blank white page which says:

Please make sure the webpack devserver is running via:
npm run watch

Please consult the repository's README for more information:
https://github.com/brave/browser-electron/blob/master/README.md

I’ve read this README, but it’s about downloading and installing via the git repository, which I don’t want to do right now unless I have to.

Please could anyone help? :slight_smile:


#2

I think you probably have NODE_ENV globally defined which is causing Brave to think it is in dev mode. If you could move whatever needs that into the project’s local config that would be ideal for now.

We’re looking into ignoring NODE_ENV for production builds here:


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.