uBlockOrigin (uBO) causing high CPU in Brave since March 10th update

Description of the issue:
Since the 10th March release of Brave, CPU of the uBO extension jumps when opening a webpage. Page either doesn’t load or just get the spinner for ages. Before the update, it worked normally.

How can this issue be reproduced?

  1. Install Brave V1.36.112 and uBO extension. This issue happened with the latest v1.41.8
  2. Enable the uBO extension.
  3. Open or click reload any webpage
  4. Check the CPU usage in Task Manager
  5. Disable the extension
  6. Reload - page will load fine

Brave Version( check About Brave):
1.36.112 Chromium: 90.0.4844.51 (offical build) (64-bit)

Additional Information:
Never any problems before the March 10th update of Brave, and uBO has not been updated for ages.

I don’t have any help to offer on this one. Just wanting to ask, why use uBO? Brave has been all I’ve needed to block all ads and all. What is it that uBO is doing for you that Brave isn’t doing by default? (sincerely asking out of curiosity)

Thank you for reaching out.
Going to take a look at this on my end and see if i can reproduce. I’m also curious if the high CPU spike occurs if you were to disable Brave Shields for the site while leaving uBO enabled?

Thanks for the reply.
I just tested what you said and the same problem occurs whether shields are up or not (I normally have them up).
I turned the shields off and left uBO on, reran the same steps, and again the CPU shot up.

Are you looking at the browser task manager to measure CPU usage or the system task manager?

Just been using uBO for donkey’s years! It’s off now anyway, because of this issue no webpage will load, so maybe I will uninstall it if I see no benefits. Thanks.

Hi, I used the system Task Manager. When I disabled the extension, the task with the high CPU disappeared, when I enabled it, the task ith the high CPU appeared again, so I knew it was uBO

Can you tell or show me (screenshot of task manager window) what specific task it was that was hogging the resources?

An additional test — can you try creating a fresh browser profile, installing uBO on it and trying to reproduce these results again? Note that when performing this test, you should only have one browser window open (the newly created profile).

I’m unable to reproduce this on my end — I’ve installed uBO in Brave on my Windows OS and am seeing normal resource usage with or without it enabled.

Attached are images from Process Explorer, Windows Task Manager, and Brave’s task manger. They don’t seem to say much!
I’ll try the profile option now. Thanks.

Did you test the issue with a fresh profile the way I mentioned previously?

Yes just tried it. No problems when I created a new profile with all the defaults, and installed uBO.
Must be something funny going on with a profile setting, new Brave, and uBO then I suppose?

Yeah curious.
Do you have any other extensions installed at this time?

Yes a few, but I disabled all of them when I was investigating this problem.
It was only when I enabled uBO that the issue happened.

Have you tried clearing your cache/browsing data in your main profile? Wondering if there’s just some “bad bits” stuck somewhere that need to be shaken loose.

Yeah, maybe. I’ll give that a go now. It’ll close this session I think but I’ll log back on once it’s done…1 min…

Cleared cache and cookies, but same problem.

Maybe I could create a new profile again, and turn on the settings one by one to see if I can locate the problem, if that’s the issue, that way?

That could certainly reveal the culprit — although the process is a bit arduous. In the interim, I’ve reached out to a few team members to see if they have any additional ideas.

Ok, will try to duplicate my main profile settings and let you know if anything happens. Thanks a mill for your help.

1 Like

I duplicated all the settings but no issue.
I did notice something interesting though: I didn’t have to load a webpage to get the high CPU - I enabled the extension and displayed the developer tools (I was going to load a webpage and check the Performance tab), but uBO triggered the high CPU immediately when the developer tools screen displayed.
This made me remember that I uninstalled an old version of Visual Studio yesterday. Wonder if there’s a link there somewhere?