Ublock custom filter not working on Brave, working on Firefox

Description of the issue:
I am defining a custom filter list to delete several parts of a webpage matching a given criteria and after testing it on Brave it doesn’t work, but testing the same filter in Firefox does work

How can this issue be reproduced?
The example will be dependent on the content of the webpage at the moment of the visit

  1. go to chollometro.com and for the sake of this example, pick the username of the first listed entry (in the screenshot below, it’s “srpeixe”)

  1. Go to brave://settings/shields/filters and add chollometro.com##article:has(span:has-text(/srpeixe/i)) in the text box of “Create custom filter”
  2. Save and reload chollometro.com

Expected result:
The entry and all of the entries with the same autor must disappear, but they don’t.

Brave Version( check About Brave):

Key Value
Brave 1.62.165 Chromium: 121.0.6167.184 (Official Build) (64-bit)
Revision 646e9a49ef45084cb2341eb1e9afabc339004a27
OS Linux
JavaScript V8 12.1.285.28

Additional Information:
Adding the same string to uBlock Origin in Firefox successfully deletes the entry (122.0.1 (64-bit) Mozilla Firefox for Fedora, uBlock Origin 1.55.0)

Update: same happens on Windows:

Brave version:

Key Value
Brave 1.62.165 Chromium: 121.0.6167.184 (Build oficial) (64 bits)
Revisión 646e9a49ef45084cb2341eb1e9afabc339004a27
Sistema operativo Windows 10 Version 22H2 (Build 19045.3930)
JavaScript V8 12.1.285.28

Firefox version:
Mozilla Firefox 122.0.1 (64-bit) uBlock Origin 1.55.0

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.