Twitter / X won't load comments - have to refresh often ***SOLVED - extension issue***

Description of the issue:
Scripting seems to break often when using Twitter/X. It can happen every few minutes or if I am lucky it will work properly for 30min. It causes comments not to load and inability to like posts. Sometimes images or video will not load, or not play.
It does not matter how the shields are set or even if they are completely off.
I tried memory saver on and off. Doesn’t have any effect (and probaby not suspending any tabs with 32gb ram).
This has been happening for several versions (since I’ve been using Brave on Linux). I switched to Beta in hopes I would receive the fix faster (and I prefer new layout, additionally light dark switching now working).

Screenshot from 2023-12-13 10-53-52

How can this issue be reproduced?

  1. use twitter.com for random amount of time. A few minutes up to 30-40min.
  2. Opening posts will give you the above error. Clicking retry does not work.
  3. The only remedy is a manual refresh of the page.

Expected result:
Not having to manually refresh the page every ~10min to maintain functionality.

Brave Version( check About Brave):
v162.105

Additional Information:
Solved by disabling ProtonVPN extension and running system-wide VPN. Chromium has a bug that causes issues with that extension (prompting for login regularly) so I thought it might cause other issues. Lo and behold, it does.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.