Twitter videos and gifs won't play (audio can be heard, though)


The posted videos and gifs on Twitter are loading correctly, but they will not play. The audio DOES play, however. I tried turning off the site shields, but this did not help. (“Block scripts” was turned off by default). I couldn’t find a solution for this in any of the forums.


What Brave version and OS are you using? Did you try with shields turned off?


Windows 10 (Home) and, yes, I tried it with the shields turned off.


Here are two settings that you can try toggling that might fix the problem for you (as it has for me) in many cases.

For some users, embedded video playing problems are caused by the “Use hardware acceleration when available” setting in advanced preferences about:preferences#advanced.

Try restarting the browser after disabling and seeing if that fixes the problem.

If not, what has worked for me quite reliably (just tested it twice) is the “Use Strict Site Isolation (Experimental)” feature in preferences, which you may have to disable.

Edit: See Strict Site Isolation Mode breaks Embedded Media Video Playback


Thanks. It was the hardware acceleration. Everything works.

Phil Hankins

505 E. 10th St., Apt. 7

Libby, MT 59923

closed #6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.