Twitter/Twitter Beta issue - Delay on right click

performance
#1

I have started using Brave browser a few days ago and I am really enjoying it, especially its speed. But, there is one performance issue that I am not really happy about.

When I right click on an image or link on Twitter, I have to wait at least 2-3 seconds for the right-click menu to appear. I did not encounter the same issue on any other website, but as it is a really popular website, I wanted to report this issue (and I do use right click frequently on Twitter, so also for selfish reasons).

Good luck with the development and thanks for creating this great browser.

2 Likes

#2

@poohdini,
I recently helped a user with a similar issue. Can you try disabling Hardware Acceleration and see if that helps?
Settings --> Advanced --> System --> Hardware Acceleration

1 Like

#3

That didn’t fix it for me

1 Like

#4

This did not have any effect, unfortunately. I did relaunch the browser.

0 Likes

#5

@Marcel, glad to hear that helped!
@poohdini, is there any way you’d be willing to take a short screen recording of the behavior as you see it? Would help diagnose what the issue may be.
We have some free/easy resources for recording and/or image capturing screen activity in our Community Resources section if you don’t have a way to do this already.

0 Likes

#6

You must have misunderstood something, it hasn’t changed anything for me as well (In my gif I press right-click before I start to circle around with the cursor, it takes about 3 seconds to open)

0 Likes

#7

@Marcel, apologies - it’s been a long day. Read that as “that worked for me”! My bad.
Does it function properly if you turn Shields off on Twitter?

0 Likes

#8

Nope, I’ve already tried that. Btw this only happens on the new Twitter Beta design (which is https://mobile.twitter.com), but not in Chrome, Firefox and Opera.

:pencil2:(oops, it’s https://mobile.twitter.com and not https://twitter.com/mobile :sweat_smile:)

0 Likes

Right click hangs on mobile twitter
#9

Here it is. I do right-click immediately at the beginning of the recording.

I also have to state that it happens on Twitter Beta, but only on Brave.

0 Likes

#10

Can you (anyone) test and confirm whether or not you’re experiencing on both Twitter Beta and “regular” Twitter?

0 Likes

#11

I’m experiencing this on the new Twitter only (twitter beta). On the legacy version it works just fine.

2 Likes

#12

I’ve created a Pull Request for a fix here https://github.com/brave/brave-extension/pull/94

0 Likes

#13

Note that we have an issue opened here for this on our GitHub:

1 Like

#14

@Mattches thanks! I’ve added a comment there to reference the PR I opened on brave-extension

2 Likes

closed #15

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes