Twitch Automatically Downgrades Quality When Not in Focus

Description of the issue: Streaming Video on Twitch Automatically Downgrades Quality When Tab Not in Focus

How can this issue be reproduced?

  1. Launch Brave
  2. Go to your favorite streamer and start watching a video
  3. Manually set the video quality as high as it will go (not “automatic” – 1080p (source))
  4. Open a new tab and do whatever you’re gonna do
  5. Swap back to twitch tab and notice it is at worst quality. Even shows 360p near the Settings Cog.
  6. Wait a second or two
  7. Video will pop back to what you originally set it to
  8. Verify resolution with the Settings Cog (it will be what you set it to, not the lower value)
  9. ???

Expected result:
One would expect for the video not to automatically go to a lesser quality. One would expect the video to stay at the resolution one chose and not bounce back and forth (connection speed/quality is not an issue).

Brave Version: v1.48.167 (Feb 16, 2023)

Additional Information:
This seems to only be an issue with I don’t get this behavior with other sites such as YouTube, Rumble, Vimeo, Amazon. Unsure if it’s their implementation of the stream or what. This is especially annoying when one uses Picture-in-Picture since the reduced quality stays poor until you bring the tab back into focus. This makes the Picture-in-Picture window essentially audio-only since the image to too pixelated to really make anything out =(

Searched this issue and only found a couple of threads. One was about blurry text or browser window itself. There was a similar thread like this regarding YouTube but that thread is close as of '22 I believe.

1 Like

Hello there @nasch007 please accept my apologies for this inconvenience.

In this case, try disabling Hardware Acceleration in settings to see if this resolves the issue. You’ll find this in brave://settings/system > Use hardware acceleration when available > toggle off > relaunch Brave.

Let me know if that works.

Thank you for the suggestion. I tried disabling HW Acceleration and relaunching Brave. Unfortunately, same result. When I switch back to the tab, the video quality has been set to 360p. After a couple of seconds it switch back to 1080p.

Is this a site behavior? Or a Brave behavior you think?


1 Like

Does this also happen if you open Twitch in other Chromium based browsers such as Chrome or Edge? If it does it could be a chromium issue, if it does not happen, this can be related to Brave.

Let me know if it happens on other browsers.


I will try it in Edge tonight; Brave and Edge are the only two browsers that are installed.

Thanks for the suggestion and I will report back.

1 Like

@nasch007 thanks for your response and let me know if the issue persist.

Be waiting for your response.

Good morning,

I attempted to use Edge last night and it had the same exact behavior. I guess it’s not Brave-specific then, but possibly Chromium-based browser specific or something to do with Twitch’s media implementation. I’m not sure how the web server/web page would know it’s out of focus or if that’s the web browser since I’m not too knowledgeable about this sort of stuff.

Thank you for your assistance with this and have you been able to reproduce or validate the issue?

1 Like

Do you have other programs such as VPN’s or antivirus active while using both browsers? If that’s the case, try disabling them to see if that changes anything.

On my end I only experienced a little stuttering from time to time, however only when I have other programs that consume a lot of GPU resources.

I do use NordVPN; I’ve experienced this behavior both with and without being connected to the VPN – no difference.

I have an RTX 3080 and a very stable 150Mbps connection with low ping so stuttering is never an issue for me, it just seems to automatically select a lower quality setting when the tab is in the background. I’m wondering if this is a Chromium behavior or Twitch has something in their code itself that does this. I don’t experience this on Rumble or YouTube so it may not be something Brave is able to account for.

1 Like

Does disabling or enabling Vulkan on your settings change this behavior To find this flag, please go to brave://flags > Search Vulkan > Disable Vulkan > Reset.

Let me know if that makes any change.

I don’t have a “Disable Vulkan”, I have:


Use vulkan as the graphics backend. – Windows, Linux, Android

I set it to disabled and it had the same behavior. I’m not sure this will be solvable by Brave, it seems like it must be intended behavior by Chromium base. If you really wanna solve it (I would like to as I distinctly did not have this issue using Firefox ESR) let me know if there is anything else I can try to help.

Thank you!

1 Like

If this issue is persistent on other chromium based browsers it would seem the issue/behavior is related to chromium.

If you try on any of the incognito/private windows from Brave, Edge or Chrome, does the the video quality downgrade?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.