Turned off auto contribute isn't off

Hi,

after I verified my wallet, I turned off the auto contribution but my BAT are still being donated. How can I prevent this in the future and finally turn off the auto contribution?

Thanks for help

1 Like

same this month on my side ! i disabled auto spend … but browser does activate by himself … so bravebrowser has earned 6 BAT and spend from my uphold wallet 20 BAT … and Bravesupport dont answer :frowning: