Trouble loading PDF pages

Description of the issue: PDF pages do not load. When refreshed multiple times, it may load one of the times.
How can this issue be reproduced?

  1. This issue was seen on Ubuntu 20.04 after updating the system. Along with Brave, some other packages (including linux-header*) were updated.
  2. Google Chrome could load the PDF pages correctly. This issue is not confined to any specific website.
  3. This issue is not present in Ubuntu 22.04 for the same version. Another difference between the system was that the system with the issue had Nvidia graphics, while the other had AMD.
  4. Overall, difficult to reproduce in another system.

Expected result: PDF pages must load fully in the first try itself (without needing any refreshed)

Brave Version( check About Brave): 1.39.120

Additional Information: Please comment if you want any additional diagnostics or system details. I would be more than willing to help.

Update: Problem persists in version 1.39.122. Checked the same version in another laptop running Ubuntu 22.04 with another Nvidia graphics card. There was no issue there. I feel it is very specific to the system settings that I have. If there are any diagnostics that I can run to detect it, please let me know.


Might help:

Can't download or save on linux

Thanks, 289wk. The problem mentioned there was not related but I found out something when I tried their instructions. The problem is not present in a guest profile. That’s a clue I think.

Is this a specific PDF/PDF site or is it any/all PDF files?

Additionally, do you have any extensions installed in the browser (in your main profile) at this time? I’m wondering if one of them may be causing some sort of conflict with viewing PDFs in browser.

Hi Mattches. No, this is not specific to any site. I had a few extensions installed in my old profile (I created a new one). I installed two of them: Google Scholar and Google Translate in the new profile and I am still not getting any errors. I synced the new profile with the old profile (except for the extensions, somehow). So far, no issues.

My laptop was connected to the old profile and it did not face any problems. So I don’t know to what extent it is linked to the profile.

1 Like

Very strange. I’ll keep this thread open — please let me know if the issue reappears.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.