Transferred wrong crypto token to brave wallet

Hi, I accidentally transferred GUSD from blockfi to my brave wallet account, which I did not realize was Ethereum only. Did not see that when I Set it up… the transaction was confirmed successful and I am positive I entered my own wallet address but nothing shows up. Is there any way to convert the GUSD i attempted to transfer to ETC?

1 Like

@amyqchow21 I’m assuming you’ll need to add it. You’ll see instructions at Adding new asset to Brave Wallet

A second option, which is actually easier than the linked part, might be just to add it from CoinMarketCap. I do believe you’re speaking of Gemini USD which would be https://coinmarketcap.com/currencies/gemini-dollar/

When you go there, you’ll see Contracts part and it lists some wallets. If you click on the MetaMask fox thing image you’ll get a pop-up asking if you want to add the coin to your wallet. Screenshot below:

image

Just click Add and it will put in the info to Wallet for you, instead of you navigating and typing things in. I believe you should then see it visible in your Wallet (though might still need to enable it)

Thank you very much, I added GUSD and see it however I do not have the expected amount that my withdrawal from blockfi was approved for. Based on the instruction you sent, it should have indeed been in there just not visible, so something must have gone wrong on Blockfi’s end? Should it be visible immediately or could this take some time to process?

Could you please assist? I have the transaction confirmation but still not seeing it in my wallet.

@amyqchow21 is the link I provided the correct token address and all? That’s the primary thing you need to check. I just assumed and was telling you to double check.

@Mattches or @Evan123 may be able to better provide more information on what to look into.

Yes, and I did check the other method just to make sure GUSD was appearing. I have all the transaction “receipts” (not sure what they are called in the crypto world… its the site that has the transaction details) I have checked the wallet number is correct many times and refreshed the wallet and not seeing the money I transferred. thanks

I haven’t heard anything from anyone else yet. please assist.

@Mattches @Evan123 please assist. I have all the documentation that the funds should be in my wallet. I can DM the info to someone if it helps

Sending you a DM now. Thanks!

1 Like

Thanks for the help everyone, removing the GUSD token and adding it again via a custom token worked for some reason

2 Likes

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.