Trackpad Sensitivity too high while scrolling

Whenever I use trackpad in my laptop to scroll down pages, the scroll sensitivity seems too high in the browser. Though connecting external mouse solves the problem I am using Lenovo L340 Laptop. Please look into this…

Anybody else having such trouble?

@Throttle,
Thank you for reaching out. Can you please confirm that this only happens in Brave and not on other browser/apps as well?

Yeh … Sensitivity remains fine in Chrome, Edge and even in word documents…
It’s just Brave browser…

I’ve mentioned earlier, If I connect external mouse and scroll through it, things are fine…
It’s just trackpad and specifically in Brave only.

1 Like

Try going to settings on Brave and search for “hardware acceleration” try seeing if there’s a difference between it being switched on and it being switched off. I hope this helps. Also make sure Brave Browser is up to date by clicking the menu button and clicking on “About.” It will automatically check if you have the latest version. Cheers!

Tried that but unfortunately no joy…
Browser is also up to date.
Actually, I have had this problem from Day 1 …

1 Like

Im having same issue on same laptop, only since windows update though. Did you find a fix, it’s making brave unusable for browsing!

No, still trying to figure it out.
Tried every possible way but the problem still persists.
Time being I’m using external mouse which makes things fine.