"Trackers & ads blocking" must be totally disabled to connect Metamask to localhost

Description of the issue:
If I try to switch networks in Metamask to localhost, Metamask fails to connect.
How can this issue be reproduced?

  1. Switch Metamask network to http://localhost:8545
  2. Metamask loading spinner appears, followed by failure message asking to give up or retry

If I disable the global “Trackers & ads blocking” option in the Brave Shields settings, Metamask connects successfully.

Expected result:

I expect Metamask to be allowed to connect to localhost without the browser ad blocker getting in the way. Alternatively, I expect a setting where you can whitelist extensions.

Brave Version( check About Brave):
1.21.73

Additional Information:
When “Trackers & ads blocking” is set to standard, if you try to add a new localhost network to Metamask, it will complain that it could not locate the Chain ID, and questions whether you have entered the RPC URL correctly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.