Touchpad scrolling stops working

I am using Brave 0.24.0, but the issue has been the same in prior versions. When browsing various news sites and scrolling using the touchpad (Dell XPS 13 running Windows 10 64bit), scrolling stops randomly. There are only two ways to ‘unfreeze’ touchpad scrolling:

  1. Restart Brave, or,
  2. Open (any) link in a new tab

There is no discernible connection to any activity on the page, it appears to stop working randomly. Scrolling with the scroll bar or the up and down keys still works, just not using the touchpad. Changing tabs does not unfreeze the touchpad scrolling, but opening a link in a new tab always works.

Hi @planius,

Just want to make sure. Did you have_Site isolation_ enabled under Preferences > Security?

Thanks
:slightly_smiling_face:

No, Site Isolation is disabled.
I tried enabling/disabling smooth scrolling, but that hasn’t made a difference.
I don’t have any extensions installed, either.

Stopped again. Here is a screenshot. Was scrolling on http://spiegel.de homepage.

We’ve got a few open track/touchpad related issues logged:
https://github.com/brave/browser-laptop/issues/9888
https://github.com/brave/browser-laptop/issues/15217
https://github.com/brave/browser-laptop/issues/8439

However, a better fix for this would be to switch over to the Brave Beta build recently released to the public. It offers much more functionality, support for extensions, and fixes several known issues in our Muon (v0.24.0) build. Here are some links to get you started:

Brave Beta Download
Official Beta Announcement
Brave Beta Support here in Community

Additional resources:

Brave Software Twitter
Brave Support Twitter
BATProject Reddit

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.