Tor is always disconnected

Fedora 37

Brave TOR no longer connects.

Two months TOR itself no long connected, but Brave’s did. Now it is the opposite. TOR connects but Brave’s does not.

There is no activity in my iptables logs when opening Brave’s TOR.

To reproduce, go to the hamburger and open Private Windows with TOR

Hello @ToddAndMargo

Thanks for bringing this to our attention and I’m sorry to hear you are going through this. Could you kindly try to install the Beta or Nightly version of Brave to see if the issue persist?

Be waiting for your response!

Hello @ToddAndMargo

go to brave://settings/privacy and enable Use Bridges then reload your tor window again
if it did not work try different bridge

hope that help and have a nice day :slight_smile:

bridges obfs4, snowflake, meek-azure made no difference

could you try to request bridge from tor
Request a bridge from

Excellent directions on installing the nightly from the Fedora repo! And you separted the nightly from the general release. Class act! (But you did forget to install a “launcher” for the nightly. I made my own.) Teh black theme makes the tso easy to tell apart. (I do not care for the black theme, but I can change that.)

rpm -qa brave-browser*


And no symptom change.

If it helps, the real TOR has a bar that goes across the screen when it is trying to connect. Brave’s does not. Also TOR has the option to automatically connect when it starts. Plus a “connect” button, if you are not using that feature. I can’t find any such things in Brave’s.

Could it be so simple as the connect button is missing? I have tried clicking on the “disconnected” button. No joy.

I was not sent an eMail notifying me of the two above replies.

Firewall log was quiet will all the above tests

most probably it’s the isp that block it not your firewall

did you tried this

“Can’t request at CAPTCHA. Try again later”


I am handy with both traceroute and nmap. Would they be of any help?

Does this have anything to do with?

could be i am not sure

Tester brave-browser-1.49.120-1.x86_64 in a virtual machine of Fedora 37. No symptom change.

Also, my Internet is a business account and there is no fire walling by the provider.

sorry i do not know what could be the cause

hi @Alice2095 do you have any suggestion about that?

If you can tell me what ports may be being blocked, I can do a trace on them. I am handy with both traceroute (the Linux one that I can specify tcp or udp or icmp) and nmap.

I have noticed that Brave’s TOR works from my customer’s Windows machines, but not my Windows Virtual machines.

try netstate for your working device and notice the connections then see how it work on your vm

I get pages of stuff. Is there anything I can grep on?

netstat -b | findstr word replace word in this command with the tor exe file name

then replace it with brave then try to ping the ip in case of brave and see if something in the network block it but open only one tab in tor mode and nothing else in brave to make it easier to troubleshot

I am in Linux, both commands error out.

If you tell me the

  1. the ip,
  2. the protocol (TCP, UDP, etc), and
  3. the port you are using to connect,

I can find the culprit almost instantly.

Today’s nightly is not working either. The real TOR is though.

Q. Are using using a different IP, protocol, and port than the real TOR?

Hello @ToddAndMargo

first i am a user same as you

here you said you the issue with windows machine that why i think you use windows

netstat --programs | grep word

which port it use i can not tell

that why i said earilier to open only tor on the machine that work and monitor which port it use then check the one that has the issue and see if it issue with port block so something else

hope that help and have a nice day :slight_smile: