Top Site Widgets Keep Vanishing

Description of the issue:
Top Sites widgets appear on the Homepage but when I reopen Brave they’re gone.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Visit any page you’d want to add a widget.
  2. A widget appears on a New Tab
  3. Relaunch or refresh the tab. The widget will disappear.
  4. I’ve reset the settings to default and same thing happens even after mutiple visits to a site.

Actual Result (gifs and screenshots are welcome!):
Widgets vanish.
Expected result:
Widgets will save or “Stick”

Reproduces how often:
Amost every time.

Operating System and Brave Version(See the About Brave page in the main menu):
macOS Big Sur 11.2.3
Version 1.21.77 Chromium: 89.0.4389.90 (Official Build) (x86_64)
](https://brave.com/latest/)

Additional Information:
Thank you for your help!

@jbabbott,
To ensure I understand your issue correctly, you’re saying that you add a top-site to the top-sites widget, refresh, then the site disappears --is that correct?

Hi. Yes, correct. I appreciate any suggestions.

1 Like

So these sites, right now, are populated by visits (“top-visited sites”) which may have something to do with the behavior you’re seeing. Note that we will shortly be re-factoring the top-sites, as explained/shown here:

So at this time, on your NTP you don’t see any sites in listed in the top-sites widget?

1 Like

Hi, again.

I created a Top Sites folder under Bookmarks and added a site. No luck. I did have sone sites show up because I visited each of them a number of time but then they disappear. Thanks, yes, I saw that customization article. I’m looking forward to it!

Meanwhile here’s a setting I made sure was active and what I see.

@jbabbott,
So top-sites are pulled based on browsing history/frequency, not your bookmarks themselves. If you simply browse for long enough, you should see sites populate the widget. Have you been using the browser regularly?

Yes, Brave is my browser of choice. I had four sites appear as widgets and then—gone.

@jbabbott,
That is very strange.
Can you go to Settings --> History --> Clear browsing data and select the on exit tab in the resulting window, and see if any of the boxes here are checked?

Yes, there are three boxes checked. See attached.

Screen Shot 2021-03-23 at 8.05.14 PM.png

@jbabbott,
Thanks for confirming. So what’s happening, I believe, is that every time you exit the browser, you’re clearing your browsing history. This, as I understand, should have an effect on what sites appear here. Additionally, the thumbnail images are likely cached and subsequently then being deleted on exit.

Can you please try unchecking these boxes and then seeing if you’re able to see top-sites appear in the widget on the new tab page?

Done…see attached grabs. I’ll visit some sites and see how it goes. I’ll get back to you. And thanks for hanging in there with me!

Screen Shot 2021-03-23 at 8.33.53 PM.png

Screen Shot 2021-03-23 at 8.33.36 PM.png

Screen Shot 2021-03-23 at 8.33.20 PM.png

1 Like

@jbabbott,
My pleasure – please let me know what you find.

Will do! I want to visit as many websites as I can and see if Brave captures them as widgets. Talk with you again in the morning.

‘Morning.

I did a clean install and except for options I knew wouldn’t matter (e.g. setting my search engine to DuckDuckGo) I didn’t touch a thing…and the issue resolved. It’s possible I changed something earlier, but it’s working great now.

Thanks for your help. I appreciate your time and trouble.

Best,

John

1 Like

@jbabbott,
No worries – glad you were able to get this resolved. Please don’t hesitate to reach out if you have any other questions or concerns.