Too Much CPU utilization On Linux Arch

I have moved to Brave for compatibility. I am usually using Firefox and have no issue there.
Brave for some unknown reasons uses too much CPU for very little use.
No Video playback. A couple of pages open and that is it.
What I have done:
1 - Clean Profile
2 - Clean all cookies
3 - Disable video acceleration.
4 - Disable memory saver (my rig has 64G)
Still no go.

I have another laptop running Fedora 38 with Brave and same issue.

Logs show nothing,

Both are flatpak.

You guys have seen that issue before ?

Disabling video acceleration will use more CPU resources

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.