"This device isn't recognised" screen in Gmail

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Every time I tried to login to my Gmail account, I am getting a message “This device isn’t recognised” screen which needs to verify every time . This is really annoying and very time consuming when dealing with multiple gmail accounts.


Did the issue present with default Shields settings? YES

Does the site function as expected when Shields are turned off? - NO

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. NO:

Does the site work as expected when using Chrome? - YES, WORKS PERFECTLY.

**Brave version 1.16.68


Hello @vinit.sy07

could you update your brave and see if it still happening and have a nice day

1 Like

Oh thanks for the reply. I recently updated my browser to version 1.16.68. But this problem still exists in this version too.

See the post below for further details.

1 Like

you welcome @vinit.sy07 try what @YaoGrass said and if did not help

and also try to disable all extension and try again and if it work then enable them one by one till you get the one that cause the issue

hope that help and have a nice day

1 Like

Thanks for the reply…I have posted the image on the post…Please have a look…
I am using default settings in Brave Browser…
Although I am using Adblocker in Chrome and Edge …and this problem doesn’t exist there…

Instead of moaning about Google, I will be more concise.

One reason this could be happening is cookies. As far as im aware whitelisting cookies is not yet a feature of Brave (someone might tell us otherwise), so one solution could be stop Brave clearing cookies. By not clearing cookies, you will remain logged in to Google, and in theory, prevent as many 2 step verification prompts which are getting on your nerves.

So how do that

Go to the Google sign in page. Click your shield, click ‘All cookies allowed’

Copy, paste and enter this into your address bar: brave://settings/clearBrowserData
Click the ‘On Exit’ tab. You can uncheck all these if you if you want to keep all history etc but the main two you probably want to uncheck for the purposes of this are ‘Cookies and other site data’ along with ‘Site and shield settings. Click Save.

For increased privacy, clear cookies and history manually if you desire by following step two, but click ‘advanced’ instead of ‘On Exit’. You can select what you want to clear (or don’t), and clear it.

See how you go on with that.

Why are you receiving increased 2 step verification prompts in Brave, compared to Chrome and Edge ?

Google add their own cookies to the browser whitelist if I recall correctly, meaning youre pretty much always signed in, or there is some identifying data (which Brave could be clearing). A combination of that, along with Google taking steps to keep you using Chrome instead of another browser, leads to less verification prompts. With Edge, I don’t know what your settings are, but possibly your privacy settings are not quite as strict as Brave’s default settings. There are other privacy features of Brave which could be impacting this, but I think cookies are the best place to start trying to resolve this.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.