The shortcuts ctrl+tab and ctrl+shift+tab are switching to random tabs instead of the next tab


  1. Open a new window
  2. Open multiple new tabs
  3. Type the shortcut ctrl+tab

Expected result: switch to the next tab

Brave Version( check About Brave): 1.41.96

Additional Information: It switches to a random tab in the window.

@SilverLotus4962

Maybe . . .

It’s probably the same issue as this? Next - Previous Tab in MacOS

IMHO this ‘feature’ should be removed (backed out) of Brave since Chromium added Tab Search (Ctrl+Shift+A), but that will anger lots of folks. Unfortunately the implementation here is broken, and while it serves the original purpose, it breaks other stuff.

1 Like

Go to brave://settings/appearance scroll down and you should find: → Cycle through the most recently used tabs with Ctrl-Tab

If you have it enabled/toggled on, the tabs will not cycle in order as you are explaining in your problem, so check if you have it on and test it again because it works fine on my side (but I am on Brave Nightly though), and that’s the only setting that could modify the behavior of Ctrl+Tab.

I just turned that setting off, thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.