The 2FA removing process seems looping. The account hasn’t been reset after 3 days. Please help

I accidentally uninstalled the app for the 2-factor authentication on my phone. 3 days ago I requested the 2FA removal. Today I still cannot login to my creator account even if I’ve received a reminder yesterday saying that the missing time for the cancellation was 28 minutes. Today I’ve tried to login several times but I cannot go through the process. It says that the 2FA was not deleted already. But every time I try, the remaining time for the removing process changes. Now it says I’ve to wait 22 hrs? When I tried one hour ago it said 15 hrs. It’s very frustrating. The 2FA removing process seems looping. I did not press the cancel removal button.

Anybody is experiencing the same problem?
Please help

Thank you for reaching out to us. Let me ping someone on the publishers team to see if we can find out what’s going on.

Can you send me a DM with the email you use to login to your Creator account?

Sure, thank you for your interest

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.