Teams V2 on Brave (Linux)

Have been using Brave for ages as my go-to browser on corporate desktop. We excessively rely on Microsoft Teams, and just a few days earlier Brave started to point out that “classic Teams” soon will be sunset and I should switch to “new Teams”. Which, however, doesn’t so far at least seem accessible from within Brave. Tried that on Firefox (same Linux machine) with some user-agent switcher set to Edge, and it seems to work there. Didn’t however manage to achieve the same on Brave. Any insights, anyone? Is it possible to run “Team V2” on Linux Brave these days? Or do I just have to wait?

Hello! I was in the same boat as you

For some reason brave doesnt handle the new endpoint correctly. When I tried to access TeamsV2 directly via https://teams.microsoft.com/v2/, it was always redirecting me back to the “Classic Teams” version.

To activate the Teams V2 on Brave:

  1. Log in to Teams Classic as you would normally,
  2. Once authenticated, Open up the DevTools (Menu > More Tools > Developter Tools) OR (CTRL + Shift + I)
  3. Find and click on the “Console” tab in DevTools
  4. Type in the following string:
    window.localStorage.setItem("tmp.isOptedIntoT2Web", true)
  5. Refresh your Teams tab and TeamsV2 will now load.
    image
  6. Teams may prompt you with the following dialogue box, simply click cancel and you’ll have access to TeamsV2

If you need to change back to teams classic, you should be able to re-use that console command and replacing “true” with “false”

2 Likes

Cool, works like a charm. Thanks very much. :slightly_smiling_face:

1 Like

Awesome, thank you! it worked like a charm!

1 Like