Target="_blank" does not open new tab

Description of the issue:
Since the latest version of Brave, nothing happens when clicking a link with target="_blank" attribute, even if it is not a remote link. In earlier Brave versions it worked as expected. When right clicking the link and click “open in new tab”, the new tab opens without focus (as it should).

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Go to: http://midtjyskastro.dk/?x=Indlæg/2018 and click an item.
Go to: http://midtjyskastro.dk/?x=Aktuelt/Tidligere%20begivenheder and click a link.

Actual Result (gifs and screenshots are welcome!):

Expected result:
New tab should open when clicking a link with target="_blank".

Reproduces how often:
Always.

Operating System and Brave Version(See the About Brave page in the main menu):
Lubuntu 18.04
Windows 10 Pro, 10.0.17134
Version 0.67.124 Chromium: 76.0.3809.100 (Officiel Build) (64-bit)

Additional Information:
Firefox, Chrome and Edge still opens new tab as expected.

@apeteran,
Thank you for reaching out to us and welcome to Community :tada:
Can you provide a sample link or two in which this behavior is confirmed to occur so that I can test on my end?

Hej Mattches

Now I have updated the topic with sample link, which is failing.

@apeteran,
On my end the site appears to be working as intended – its seems as though the links the site is using aren’t set to open in a new tab in the code either, unless I’m missing something. If you hold ctrl and then click a link it should force the link to open in a new tab – can you check and see if that works on your end??

Hej Mattches

No, ctrl click does NOT open the link in a new tab either.

@apeteran,
Can you ensure you’ve updated Brave to latest version? Should be v0.67.125 at the time of writing this.

Note that on my end, ctrl + click on links in the site open in new tab as intended:

Yes, Brave version is v0.67.125

  The link you are clicking in this video does not have

target="_blank" so it opens OK. Try one of the links ending with
.pdf which have target="_blank".

  Hint: Try to hit ctrl U to see source text, scroll to near the

bottom.

@apeteran,
It looks like Brave is blocking a pop-up attempted each time I try to open a pdf. While I could still right-click --> Open link in new tab without issue, the easiest solution is to simply set the Pop-ups and redirects setting to Allow for the site in question.

You’ll find this in Menu --> Settings --> Addt'l Settings --> Site Settings --> Pop-ups and redirects. Alternatively, you can visit the website, then click the “lock” icon in the address bar, then Site settings --> Pop-ups and Redirects.

Hej Mattches

Thank you. It works. In the next Brave version the default ** Pop-ups
and redirects** should be set back to allow , as in the
ealier versions, so all browser flavors behaves alike. This will
prevent Brave users to get so frustrated like I was.

@apeteran,
Glad this worked for you, but I’d highly recommend not allowing popups/redirects for all sites – the reason these are blocked is not just because they’re intrusive and annoying, but may often leave cookies or contain malicious content. Please use caution when allowing sites or software permission/access to your browser.

This topic was automatically closed after 30 days. New replies are no longer allowed.