Takes a very long time and uses a lot of cpu to load windows 11 download page

Disclaimer: repost from #1965, go there to see the video.

Description

https://www.microsoft.com/software-download/windows11 is extremely slow to load and uses a lot of cpu. It works fine on chrome, but not brave. Tested other pages from microsoft and they work fine, only this particular page seems to have this issue.

Steps to Reproduce

Go to https://www.microsoft.com/software-download/windows11

Actual result:

Braves takes a very long time to properly load the page and uses a lot of cpu.
You can see in the following video it takes ~15s for the page to fully load and become responsive. And this is with shields down.
If shields are up, then it takes even longer, and half the time doesn’t even load, resulting in “page is unresponsive” error.

(go to the github issue to see the video, I can’t upload it here…)

Expected result:

Page loads instantly.

Reproduces how often:

100% reproducible simply by going to https://www.microsoft.com/software-download/windows11

Brave version (brave://version info)

Brave 1.32.106 Chromium: 96.0.4664.45 (Official Build) (64-bit)
Revision 76e4c1bb2ab4671b8beba3444e61c0f17584b2fc-refs/branch-heads/4664@{#947}
OS Windows 10 Version 1909 (Build 18363.900)

Other Additional Information:

  • Does the issue resolve itself when disabling Brave Shields? No
  • Does the issue resolve itself when disabling Brave Rewards? No
  • Is the issue reproducible on the latest version of Chrome? No

The site uses a lot of first-party trackers, set your shields to Ads/Trackers = Aggressive. Also noticed some microsoft domains no longer resolving, which maybe related.

Thanks, that fixed it! But why does turning the shields off not fix it as well? If the shields are down, shouldn’t brave behave like regular chrome?