Tabs previously opened do not show their proper contents when opening a link from another tab previously in that browsing session

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue: When there are a number of tabs presently open AND when clicking a link to open a new tab from one of the open tabs, it is nearly impossible to see the contents of other tabs when clicking on them. When clicking on these other tabs, the present tab display simply remains.

How can this issue be reproduced?

  1. Open at least a few tabs
  2. Go to a tab and click a link to open a new tab (in the background)
  3. Eventually go back to one of the earlier opened tabs by clicking on the tab bar
  4. The just-clicked-upon tab does NOT show the proper display; it still displays the contents of the webpage of the tab that was just viewed

Expected result: To see the currently clicked upon tab’s contents, not the previous tab’s contents.

Brave Version( check About Brave): The very latest version of Brave that was updated to the current version on August 5, 2021

Mobile Device details iPhone 11

Additional Information: none

1 Like

@treego14,
Thank you for reaching out to us with this.
Is there any way you can share a short screen recording of the behavior so I can get a clearer picture of the behavior?

I don’t really know how to do what you are requesting.

Okay, I just figured out how to do a screen recording …. says file is too big, though, to upload here.

@treego14,
Okay great. If the file is large, upload it to imgur.com, grab the link, and paste directly into the reply. It should embed the video directly in the thread.

Please note in this video, the tab-switching at the end is being accomplished by closing a tab. As each successive tab is closed, a different tab to the left is being opened but still showing a previous tab’s content.

This problem still exists in version 1.30

still exist in 1.30.1?

I have/had the same problem with iPad, but it looks like it‘s better now

Still a problem in 1.30.1 here … window display is blacked-out now, though, instead as each successive tab is closed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.