Tab runs unbearably slow

The page is tribaldex.com.
Something broke some weeks ago.
At first the tab sucked resources like it was mining monero, enough that it triggered the fans, which got me to looking.
I killed tribaldex.com, it stopped.
I complained to a more core person and that stopped happening.
But, the tab still would lock up, giving wait popup errors.
I complained some more.
They said it was brave doing it.
I can’t say, I don’t code, but I do know the tribaldex.com page is still doing it.
I don’t have any problems on any other tabs, including tabs that mine crypto while open.
Just tribaldex.com.
I have the latest update version of brave on a linux mint box.

If you can offer valid insights, I would like to hear them.
If you would like to discuss it with them, I can connect you with them.

Hello @Antisocialist, thank you for letting us know about this. Have you tried accessing this website from a different device. Can you please share a screenshot with the pop up errors you are experiencing? so we can better assist you and further investigate.

Thanks in advance.


image
image
image

I have video screencaps, but the file format is webm and I don’t know how to convert it to something acceptable here.

It seems more responsive today, I had a harder time getting it to trigger.
What led me to complain was that I was trying to place orders but whenever I clicked on anything the page would lock.
The most often occurrence was trying to use the ui as a calculator to determine price points by changing the inputs, this would lock the page and often would take 60+ seconds to clear.

I can create free accounts, if you need one to test for yourself.

Sure flick me a login/password to test, rbrown@brave.com and steps to reproduce.

Aggressive fingerprinting might have issues also.

Look for a proton mail email with Hive Account in the subject.

The same developers run keychain as run tribaldex, so talking to them directly might cut out some inefficiencies.

The most common place I ran into it was while trying to set buy and sell prices.
I’d use the ui to do the calculation for this price, then change it to that price to see what the spread was going to be.

When I attempt to login with username, fails to register my click on Login

Did you get keychain?
You can also use the posting key in peaklock, but I’m not sure about its portability.
Keychain is nearly ubiquitous in the ecosystem.

This is web three, there are hurdles.

I did, but the bravetest username, then login with keychain. which fails to register.

Have you entered the keys into keychain?


For this to grant entry you have to first put the keys into keychain.
Or, you can enter the posting key directly into peaklock.

Not seeing any of this, will get @Mattches to take a look when he’s free next

If you have at least the posting key in keychain, try hive.blog, or ecency.com, these are ui’s that write to the same chain, but I am not as familiar with them.

Tribaldex.com will also need keychain access to log you in.

Perhaps this is my own ignorance but I am unclear on what the expected behavior is. On the site you linked, if I go to login, this is as far as I can get:

I’m not seeing these options at all. I elected to download the keychain extension, but its simply prompting me to enter a “new” password. I entered one and then tried to use the test username/key you provided and it told me the login information is incorrect.

image

The red and white one is hive keychain.
image

IF you see this select ‘use keys/pwd’.
Add the posting/active key.
This will take two steps, you will have to open the popup again to add the other key.

Are you here at this point?

Sorry, but this is one of the pain hurdles that keeps us from deflating fedbook.

Sorry for the late reply. So I was able to login finally after adding all the necessary keys. However, on my end, this site appears to run just fine. Not slow nor is it slowing anything else down.

Is there perhaps a certain action/actions I need to attempt in order to force the behavior you’re seeing?

Oh, great, I thought you were another victim of the infamous hive learning curve.

So, I mostly use the ui from balances to open order to trading that token and back.
I’ll show the progression in screen caps:

I got this just now as I was checking the page.
I stopped using it for a couple days and wanted to see if it was still lagging.
It is.
image

image

The page locking up will be noticed switching between open orders and the token chosen.
Often I wlll notice it when I hover over things and the finger stays locked.
Other times it takes inputting a sell price and amount, then changing the sell price to determine the profit of the spread.
The page locks up during these various actions, for me.
I’m using linux mint, in case that makes a difference.

I sent some tokens so that you can set orders and cancel them.

So, it’s not just me.