Sync on IOS is not working on IOS

Description of the issue:

Sync on IOS device is not working.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Create a sync chain from the mac (or windows tried both).
Add IOS device to the chain.
The sync happens as expected.
Things works as expected for few hours.
After 2 days, add new bookmarks on the desktop (mac or pc) browser, open brave on IOS.
Wait for 30 mins, refresh it, close and reopen it.

Expected : new bookmarks are synced to IOS.
Actually : No new bookmarks are synced to IOS.

Please note it works again if the IOS device is removed from sync chain and then added back. But it stops working after about 2 days.

Reproduces how often:
100% of the times.

Brave Version(See the About Brave page in the main menu):
On mac OS
[Version 1.32.106 Chromium: 96.0.4664.45 (Official Build) (x86_64)]
On IOS
Version 1.32.2(21.11.4.20)

Type of devices currently running on the Sync chain in question:
Windows surface 7 (used occasionally)
Pixel 4a 5g (used occasionally)
Iphone 13 pro (THE PROBLEM)
Macbook pro 13 (intel)

Additional Information:
The most weird thing is that it works immediately after setting it up for the very first time and stops working in about 2 days.
On android it is much stable and it works.

1 Like

Hi @lovesingh25, welcome to Community :smiley:

When you are saving a bookmark, are you selecting location to save? It might take a couple seconds until it appears on your mobile/desktop device. Screen Shot 2021-11-17 at 12.05.45 PM

Please sir check my problem also and give me solution

Thank you!

Yes, I did saved it at correct place.
I also noticed it works immediately after adding IOS device to the chain but it stops working in about 2 days. I did waited for 30 mins at least for the sync but nothing happened. On my android phone new bookmarks were present.

I have to remove the IOS device and add it again and the cycle repeats.

mine just disconnects after the first day and i have to remove the ios device and re-pair.

1 Like

When I upgraded to iOS 15.x a couple of weeks ago, sync stopped working on two of my iPhones.

All bookmarks still present but the phone does not recognise the historical sync chain. it prompts me to start a new sync chain.

settings > sync on desktop brave shows last active sync with these devices Nov 10th and 11th if that coincides with a Brave update.

Yeah the problem is still the same.
I have reset up the sync every 2 days on latest ios build.