Sync not working on Google-less Android

I have recently installed a Google-less Android (well as much as it can be) on my phone and I am using microG to bypass any of the Google Play Services issues. When trying to setup Sync on the Android by scanning the QR code I receive a message stating ‘Sync could not be setup [Failed to fetch]’. I am assuming this is somehow related to the Google Play Service as I have tested a few things.

  • Tested other Android variants without the Google Play Services - Failed
  • Tested without microG installed - Failed
  • Tested with the ‘gapps’ Google Apps installed - Worked but puts Google back on the device

For reference I am using a Poco X3 and currently running crDroid OS with microG fully installed and working. It is a clean install so nothing else that could be impacting it at this time. The version of Brave I am using is 1.5.5 which was downloaded from Aptoide.

I have tried to scan the QR code from 2 separate devices and also attempted to use the text code, all failed.

Any support on this would be great as Brave is certainly my daily browser of choice.

2 Likes

Hey @lypticdna ! Welcome to the community :smiley:

Using the QR feature of the Sync service requires Google Services, however just using the codephrase should work just fine.

Hope this helped!

Porridge

1 Like

Hey @GreenBananaPorridge thanks for the reply and greeting.

I have attempted the codephrase and still encounter the same issue.

Happy to test any further suggestions though.

1 Like

The issue has now been resolved. It appears related to the version of Brave. Following the update to a more recent version (thanks to APKPure) it is now working a treat.

2 Likes

Just curious, do the rewards work, because you are running a different os and microG?

@m_rod,
At this time, Google play services and passing an Android Safteynet check are required for Rewards.

Yeah, I was just hoping that installing microG may spoof play services and pass Safetynet. I have months of sweet, sweet rewards just waiting in limbo