Sync issues on 0.19 -- Both computers think they're device ID 0


#1

This morning, I updated all of my Brave installs to 0.19.53. I’ve been using Brave since at least March, and have synced since then from my “Main” copy on Windows 7.

This morning, I wanted to sync my second copy. I noticed my Main copy did not sync since March, but sync has been turned on the whole time. Eventually by turning it off and on I was able to get it to sync.

I added my second Brave install (it’s also a Win7 machine) and it wouldn’t sync after the initial sync. (It also wouldn’t display it’s name under device ID 1, I already saw open issues for this one.) After trying to get sync to work between the two PCs for some time, I decided I would reset sync from scratch then try again.

On my Main PC, I used the “I’m new to sync” option to create a new sync. After a few seconds, device ID 0 showed up (it has no name at this time, I’m assuming due to the other bug for this) and it synced. I changed a bookmark and waited about two minutes and it updated the sync time.

I went to my second Win7 PC and setup the sync key (the passphrase) and it synced. The issue is, looks like it syncs, shows up with no name, and it also device ID 0. However, one PC does not see the other PC synced, but they’re both syncing.

Are there any suggestions for this? Perhaps it’s not completely resetting?


#2

This is a known issue when you reset sync and renable it on either of the devices, the device names is not shown but sync does initiate and work. There is an issue for this and can be tracked here
https://github.com/brave/browser-laptop/issues/8696


#3

Hey @sriram, I did see this one, and what I’m experiencing seems to be a combo of the bug you mentioned plus some other issue.

The sync name is not showing up, but on top of that I have two devices syncing with the same device ID. If I look at my one computer, it shows this:
image

If look at my other PC, it shows this:
image

Both are showing up as zero, and both look like they should be syncing successfully but they are both not shown. Originally, before I reset the sync on both, I could see both the PC IDs (0 and 1).


#4

That is correct. When reset both devices set id as 0. This should be fixed with the same issue that I linked before.


#5

I figured I’d jump into this thread rather than starting a new one though I’m unsure whether what I’ve experienced is the same issue as what’s already discussed here.

Further, reading other threads, it seems a new version of Sync is in the works which may make this comment moot.

I wrangle a few machines (desktop and laptop), all with Windows 7, one 32-bit, the others 64-bit.

I tried Brave’s Sync option dating back to at least v0.19.??, perhaps earlier, but no more recently than Oct 2017.

The first Sync operation from a desktop to a laptop more or less worked. Subsequent attempts to update failed.

What I then did: export an HTML file of bookmarks and cut-and-paste from this file on the target machines. This is clumsy.

What would help make Sync useful:

An unambiguous designation of “source” and “target” is essential.

A short selection of options would be nice, for example:
“copy” is one-way and updates the target to match what’s new / changed on the source; and
“exchange” makes source and target match each other, keeping the latest changes on both.