Sync issues across devices


#1

Can’t figure bookmark syncing out. Was working fine across 3 devices (1 OSX, 2 Linux comps). Yesterday, reset bookmarks on OSX computer. As I was doing that I could see changes were syncing over to a linux computer. But then it just seemed to stop. So, I reset the syncing on the linux computer. After a while it did finally get most everything, but one folder. Didn’t really matter, it was good enough. My other linux computer at home came out perfect!
Now I get to work today. The OSX computer, now only has 1 folder. The other linux computer at work has the same as yesterday, no change. What’s going on?

I had the OSX computer set up to sync bookmarks from. I understand that to mean that it’s let’s say the primary. The other linux computer have this off. So I assume they would only accept changes, but would not push them out.

Now I changed the OSX computer to not sync bookmarks “from” and a linux computer to sync bookmarks “from”. But no changes are happening anywhere.


#2

I see someone has posted something similar. I guess my question might then be is there a good way to reset all the sync related data? It seems like the reset button doesn’t really do that.

Also, I want to note that on the OSX computer only 2 computers show up on the Devices sync list. They are numbered with ID’s 0 and 1. On the work Linux computer, only 1 computer shows up with the ID 0. But there is no Device Name there, so I’m not exactly sure which computer it is. HOWEVER the sync time is exactly the same as for the OSX computer, which is Device 0 on the OSX computer.


#3

Thanks for taking the time to respond with this information. Sync is still in Beta, so please makes sure to keep bookmarks backed up in a safe location, in case things end up broken.

You can reset all of the sync data, by disconnecting all of the devices from sync, deleting bookmarks off of all devices except the primary devices (the device with all of the correct bookmarks), and setting up an entirely new sync group. We are continually working on improving sync, so keep Brave up-to-date to get any latest improvements.


#4

Actually this is a known issue. When Sync is reset and re-synced again the device name is not shown under the list. There is an issue logged for this and can be tracked here


#6

@fcantusaldivar https://github.com/brave/browser-laptop/issues/9355 created. Good idea!


#7

I just installed Brave (ver 0.22.669) on two desktop and one laptop machines (all Win 7 Pro) this morning. I found the Sync use model confusing, but after watching a YouTube video on how to set it up, I proceeded to turn on Sync on all three machines. Now, on the Preferences>Sync tab the correct name of the device shows but the results list under Devices is different for all three machines–and all show the ID = 0.

Issues:

  1. When you paste your code words into the text box, you cannot use the mouse to click into the field below where you enter a device name. You must use the tab key to navigate (MINOR)
  2. When I clicked the Sync button, several times nothing happened (or possibly it was working in the background?). In any event there was no feedback to the user and after waiting for over 5 minutes I twice had to close the application using Windows Task Manager (MAJOR).
  3. I added a new bookmark on synched Device A in a specific folder and the bookmark did not appear on in the same folder on Device B (MAJOR).

Sync is obviously a critical use model for people with multiple machines. These kinds of issues make it hard to leave Chrome. Is there any expected release date for fixes to these issues?

After futzing around much of the morning with Brave, I’ve got to declare defeat. Not only is syncing an issue, but there’s another major use model issue of not having bookmark folders accessible at all times on every page. This is a major issue for me. I imported my bookmarks and folders from Chrome, but they got buried three levels deep in the bookmarks hierarchy. The only way I could see to access a bookmarked page is to dedicate an open tab to the Bookmarks manager and click on it (1 click), select a folder (1 click), and then double-click on an entry (2 clicks)–as opposed to 2 clicks to do the same in Chrome. I don’t know about you, but I do a lot of jumping around from site to site all day long and doubling my clicks to do so is a non-starter.

I love the Brave’s built-in security and privacy, but Brave has to improve markedly in the management of bookmarks, folders (and syncing thereof) before I can abandon Chrome. If I’m missing something, I’d sure like to see a video that shows some tips on how to set up Brave to do what I want. I loathe Google and all it has become, but I can’t use Brave until is has mastered these use models.


#8

Confirming: under W-7, I’ve experienced similar frustration with Brave’s Sync.

The first Sync operation from a desktop to a laptop more or less worked. “More or less”: only some / not all bookmarks were transferred. Subsequent attempts to update failed.

What I then did: I used Brave’s “Bookmarks | Export Bookmarks…” function to create an HTML file of “source” computer’s bookmarks and cut-and-pasted from this file on the “target” machines. This is clumsy.

What would help make Sync useful:

An unambiguous designation of “source” and “target” is essential.

A short unambiguous selection of options is also essential, including:
“copy” is one-way and updates the target to match what’s new / changed on the source; and
“exchange” makes source and target match each other, keeping the latest changes on both.


#9

I followed steps to resetting all of the sync data as you described but on PC#2, I keep getting - Credential server response 400 : Try again.

This is preventing me from resetting. I tried again by reinstalling and still shows same message.

Any help appreciated.