Sync isn't working between computers

Description of the issue:
I set up sync on my windows computer and received the sync code, then when I enter it into my mac, no syncing happens. I can see that both machines have the same sync code but nothing actually syncs.

I have followed some troubleshooting steps, synced and unsynced then tried to resync again with a different code, still didn’t work. I’ve also selected to “sync everything”

Brave is up to date on both computers.

Any help with this will be very much appreciated. Thanks all!

@Mattches, you were very helpful when I had an issue not seeing any ads, thanks again! Wondering if you know any fixes for this? I have Brave installed on a Mac and PC, both are paying BAT rewards to the same wallet but bookmarks and tabs are not syncing? I’ve tried all the troubleshooting steps I could find on here.

Just going to ask some simple questions, just to make sure we’re not overlooking something.

Just to verify, is this selected on both devices? If not, that could be your problem.

Rewards has nothing to do with Sync, just a FYI.

Do you have anything syncing? Passwords, History, etc? Or is it just Bookmarks that’s essentially the problem?

If you go to Sync in your settings on both devices, do they show each other there? (just trying to make sure they are actually on the same sync chain)

Thanks for reaching out again and sorry for the lack of reply here. Thank you @Saoiray for picking this one up — am also interested in the answers to what @Saoiray asked above.

Thanks for the reply, yes “sync everything” is selected on both computers. Both computers also show the same sync phrase, but under “manage devices” only my windows computer is shown, not the mac. Nothing at all is syncing, not the tabs, history, nada.

It looks like they are not on the same sync chain as the Mac doesn’t show up as synced, yet they both show the same sync phrase. I even tried leaving the sync and joining a new sync chain on both devices a couple times with no luck

Update @Mattches and @Saoiray I believe the issue is the Mac. I cannot leave the sync chain on the mac, everytime I select “leave chain” nothing happens and it shows the same sync code. I can’t end the sync on the mac then start a new one. I left the sync chain with no issues on the PC. I have a feeling if I can leave the sync on the mac and try again, then sync the PC to it, it may be fixed.

I believe this is a known issue with Sync (the Leave chain button not doing it’s job). As an alternative method to leave the chain, can you please try going to brave://sync-internals and using the Disable Sync (Clear data) option. Note that this will only remove the device from the chain (it will not clear any local data):