"Sync is disabled by your administrator."

All other devices sync ok.

Under Menu|Settings|Sync|Manage your synced devices :

So do you want to try this?

You could maybe try sudo defaults write com.google.Brave SyncDisabled -bool false first and see if that’s valid, I don’t have a mac to test with. Unless you’d rather wait for a more adventurous mac user to try it first. Although it doesn’t look to me like it would do anything that couldn’t be immediately reversed, if necessary.

Something else that might provide clues would be a screenshot from brave://sync-internals/ .

that command line code didn’t change anything.

1 Like

Same issue here on Mac OS 10.11 El Capitan (latest supported version) and then on 10.13 High Sierra (v1.46.153) after both sudo defaults write com.google.Brave SyncDisabled -bool false and sudo defaults write com.google.Chrome SyncDisabled -bool false. Personally owned and operated Mac, local admin.

1 Like

P.S. I installed Google Chrome, enabled sync there, restarted Brave — same issue. Trying the nightly build now as advised in the parallel thread.

No more “Disabled by administrator” in Brave Beta (v1.48.113 Chromium 109.0.5414.74). Brave Beta asked me to unlock the keychain when started, which I did, and voila.
Screen Shot 2023-01-07 at 10.16.05 AM

1 Like

Just so y’all know, currently is the weekend so likely won’t hear from Mattches or rest of support for a couple more days.

@treeswift @deanf @Edoconte can y’all all verify a couple things for me?

  • If you Create a new profile does it show you the same message?

If it still has the issue

  • What happens if you hit Disable Sync (clear data) in brave://sync-internals? I’m guessing nothing changes, right?

Beyond that, if you go to https://brave.com/download/ and install again (don’t uninstall, just saying to install on top which might patch any issues), does anything change?

1 Like

Ah, nice. You posted the latter portion as I was typing out the above. Glad to see you kind of got that worked out.

I managed to get to the sync chain code but it was rejected (there were 25 words in the form, I erased them for obvious reasons).

Let me try Create new profile and Disable sync in the production build now.

Sync worked (with the original code) after I created a new profile (in the new profile created, same error in the original; just thought I should clarify).
“Reset settings” (in the original profile) didn’t help.

“Disable sync” in brave://sync-internals worked! (with original sync code)


Awesome. Guess we’ll have to see if it resolves the issue for @Edoconte and @deanf .

1 Like

Disable sync worked here also. Thanks.


Interesting. Nice work everyone.

@deanf was your keychain unlocked this latter attempt (when it worked)?

I’m wondering if the keychain status might have been involved . Sync does use a key, and needs to store it someplace “safe,” and presumably would use the keychain for that on macos. And, presuming further, probably cannot store or retrieve when the keychain is locked.

(If so then this would be similar to reports we’ve seen on Linux where people do a biometric unlock of the computer, but the passwordless login does not also unlock the keyring on that platform, and then they can’t see stored passwords.)

1 Like

login and local unlocked
system and system roots locked

1 Like

Glad to hear the issue was resolved here — to be clear on the behavior, the message disappeared after using the Disable Sync (clear data) option in sync-internals, correct? There weren’t any other steps to get into this working state?

1 Like

Correct. . . . . . . .


A post was split to a new topic: Sync disabled by administrator

Is it possible the system refers to YOU as administrator of your Macbook?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.