Sync documentation leads to frustration


#1

I’m fairly new to Brave, and need to sync my bookmarks. I was happy to see there is Sync available, so I wen to RTFM, and headed to https://support.brave.com/hc/en-us/articles/360021218111-How-do-I-set-up-Sync-

The issue is that although the doc mentioned running a command “brave-browser --enable-brave-sync”, it does not mention this has to be done every time you open brave. The doc makes it sound like a one-time command. It should mention that you must edit your launchers to always enable sync, and if you do not, next time you close Brave and re-open it with the standard launchers, sync will not be enabled.

The doc should make that point clear, and explain how to edit launchers for the supported platforms covered in that doc (Windows, MacOS and Linux).

Good documention mentions tripping points. Great documentation navigates users through them. This doc does neither.


#2

Those instructions cover mac, ubuntu and windows operating systems.
Also, you should not have to edit the Sync flag in every time if you’re doing it correctly.
What operating system are you using?


#3

I am using Ubuntu 16.04.5 LTS (xenial) running Unity, and mac running sierra. On both platforms I followed the doc, closing all instances of Brave, launching it with the --enable-brave-sync flag, verified that sync was now available in settings. On both platforms, after closing that instance and using the launcher again, the sync settings were no longer available because it was not explicitly launched with --enable-brave-sync when using the standard launcher.


#4

I have not yet encountered this. I was able to set the flag once and leave it alone. Sync has been enabled since. Can I see the shortcut path you edited with the flag?

Also, that article is written so that anybody can pick up and learn how to Sync their data. The fact that your system/setup is displaying undesirable behavior is not indicative of the article being “too advanced” for anyone to use. It means either there’s a bug of some kind, or there’s something wrong with the way you set it up.


#5

It is not a “bug” in my system or anything I did wrong. I did what the doc says, but the changes do not persist once the running brave process is closed, unless it is again launched manually from a terminal session, appending the --enable-brave-sync option to the end of the command.

Here is what I did on my mac. The doc says “Run the below command in your favorite Terminal application”. My favorite is iTerm, so I opened up iTerm and ran the command given
" /Applications/Brave\ Browser.app/Contents/macOS/Brave\ Browser --enable-brave-sync"
Already there is a minor typo, as “macOS” should be “MacOS”, and won’t work otherwise since mac is case-sensitive unlike windows.

My mac now had brave running with sync enabled. I then closed brave, and opened it again, but this time how I normally would, with the launcher in my doc (also tried with Brave directly from the Applications folder), but now sync is not enabled. Makes sense, since you have to tell brave to enable sync every time you launch it, which is the point not mentioned in the doc, as I previously explained.

Here is what I did on my linux box, per the instructions which say to “1. close brave. 2. Run your favorite terminal emulator. 3. In the terminal, run: brave-browser --enable-brave-sync”. My terminal is gnome terminal, so after closing all instances of brave, I ran the given command in my terminal and as expected Brave opened up with sync enabled. I then closed Brave and opened it like I normally do, with the Unity (doc) launcher and sync was not enabled. Hence, opening it once with ‘–enable-brave-sync’ does not persist the setting across launches. It must be launched every time with that setting, meaning you either have to open it by typing a command into a terminal every time, or edit your launcher, which is the point not mentioned in the doc as I stated before.

Now that you know exactly what I did, if you still think I did something wrong, tell me what it was. Don’t vaguely claim something is buggy with my systems. It seems you did not understand this, as you thought opening it once with the sync flag would leave that enabled for every subsequent launch which clearly it does not. If you still don’t understand, I can create a youtube video on a fresh installation of Linux and show you what I just described in words. I’d rather not since I work for a living. My only point is someone should update the doc to make mention of this point. If I have the permissions I can update the document myself since it appears I have a better understanding of this. Let me know how I can do that, as I am new to the Brave community.

Thanks


#6

:+1:
My bad. FTFY:


#7

Thanks for adding in that note after each section. It is a good start, and hopefully will clarify to future users how things work.


#8