Sync Brave to Brave-dev on same computer is a no-op

sync
#1

Description of the issue:
Trying to set up sync for a new install of the Brave dev browser fails as clicking “Confirm sync code” flashes but does nothing and give no error

Steps to Reproduce (add as many as necessary):

  1. Install latest Brave 0.61.51
  2. Install latest Dev release 0.63.4
  3. Create new sync chain in Brave and copy code, set up sync in Brave Dev for computer-to computer with “I have a chain” and enter code.
  4. Click “Confirm sync code”

I’m doing this on the same machine because I only have one laptop and expect sync to get stuff into my new dev browser without manual setup.

Actual Result (gifs and screenshots are welcome!):

Nothing happens. No error. No sync. Still wants me to confirm sync code.

Expected result:

Stuff is synced to my dev Brave browser install.

Reproduces how often:

All the time

Brave Version(about:brave):

See above

Reproducible on current live release (yes/no):

Yes

Additional Information:

MacOS 10.14.3

0 Likes

#2

@O1O1O1O Thanks for reaching out!. The issue is not reproducible on Windows 10 x64, I have tried to set up sync between Dev (0.63.4) and Release version (0.61.51) on the same laptop - Able to setup sync successfully, bookmarks synced on both devices without any issue.

The user is seeing the issue on MacOS 10.14.3. Could be mac specific issue not sure.

@Mattches Could you try this on your Mac OS and assist user accordingly?

Thanks!

1 Like

#3

@O1O1O1O,
I too am unable to reproduce this issue on my macOS 10.14.3 machine or my Windows 10 machine. The process itself may be the issue. You should already have the bookmarks on one of the builds you’d like to Sync to – I’m assuming you’re moving from Release channel --> Dev Channel. Therefore, the process should be:

  1. Open Brave v0.61.51 [Menu] --> Settings --> Sync --> View Sync Code
  2. Copy the code found here
  3. Open Brave Dev (v0.63.4) [Menu] --> Settings --> Sync --> I Have a Sync Code
  4. Paste the Sync code from clipboard here and Sync

Can you retry the Sync process with those steps exactly?

0 Likes

#4

Yes that’s exactly what I’ve been trying and exactly the scenario of Release Channel -> Dev I’m wanting to sync. My 61.51 browser sits there at “Looking for new device” and the Dev browser doesn’t do anything when I click “confirm code”. The button flashes and nothing.

I’ve disabled my corporate firewall. I do have Docker and NordVPN installed but they aren’t running.

If you need me to fire up some network tracing software to see what is going on let me know, I can do that. Would it help if I used separate machines? I have another laptop with Linux I could try.

0 Likes

#5

@O1O1O1O,
Testing on separate machines would help rule out a few possibilities, definitely worth a shot. Extensions may be getting in the way even if they’re not enabled, but I think that’s unlikely.

Test using separate machines and let me know if it works.

0 Likes

#6

Sorry about the delay. I tried a sync initiated on my phone (Android) to laptop and using both the main and dev Brave browser. Same behavior.

I disabled my only extension (LastPass) and still no change.

I opened the developer console and tried to figure out what was happening when I clicked the button in the sync window. Looks like nothing… no network traffic at all. But I did notice when I bring up the sync tab the JS console on the dev channel Brave shows an error:

VM13:1 Uncaught ReferenceError: brave_new_tab is not defined
at :1:1

Is that just a spurious error or something significant? I don’t see this on the main Brave browser version.

0 Likes

#7

@O1O1O1O,
The reason you’re seeing this may be because of the difference in the Chromium versions between the two browsers. I’m also curious if there’s some sort of profile corruption happening.

Try creating a new profile (in Dev) by using the “people” button next to the main menu --> Manage People --> Add Person to create a new profile. Then, try to Sync Release --> Dev as you did previously by performing the steps above.

Let me know if the result is any different.

0 Likes

#8

You nailed it! Created a new profile in dev and I was able to sync with the non-dev browser - and on the same machine too. Thank you!

I assume it is intentional that I have to manually export and import the wallet separately?

1 Like

#9

Yes, for now. We plan to implement wallet/rewards import in the future.
Glad to hear this worked for you :slight_smile:

1 Like

closed #10
0 Likes