Switch between windows changed on 1.56.11

Brave added keyboard customization in latest update, a key in the browser can override what the OS expects or an old behavior about the Browser, which is not a good behavior but it can happen and maybe that’s the issue.
That’s why I said you have to check it and make sure nothing is conflicting with the Keyboard Customization feature and if not, you have to disable it if it is causing issues until resolved, because apparently nobody with a MacOS uses Nightly to give feedback and find the bugs but then they complain how things don’t work, just like Linux users, so when it hits stable, then nobody intercepted the bugs because nobody cared to really test it.
I reported many bugs on with keyboard customization, but some stuff are specific to each OS, and I only reported from a Windows computer.

So, yes, Brave is the one changing and implementing a feature that didn’t have before and might be affecting MacOS’s system shortcuts.

brave://flags/#brave-commands

Did you try to clear the customized shortcut in Brave to see if that solved the issue? since you say it is bound to “show settings”, then maybe that’s what causing the issue?
Did you try to change the shortcut in System Prefs > Keyboard > Shortcuts > Keyboard and see if it works with other combination?

I found that the feature is called Move focus to next window and it is **CMD + ** and not **~**, so that might also have to do with it, at least in this screenshot and most websites I saw, it was with and not ~
This is where I saw it anyway, I am a Windows person.

But anyway, that’s why I said, if it doesn’t work because Brave is overriding something it shouldn’t and it is messing with the system OS behavior, then it is better if you disable it. Unless you will customize Brave keyboard shortcuts, then it is better if you disable it if it is causing issues.
At least for now it can be disabled.

1 Like