Suddenly Brave switching to Chrome and bringing up wrong email account for forwarding

Description of the issue:
When I go to forward via email a website address or text from a website on Brave, I am switched to Chrome and a different (and wrong) email account is coming up. How can I change back to the correct email? Brave is my default Browser.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
When on a website page
click File, Share, Email link

and suddenly on Chrome, not Brave, with wrong email account and no way to select another email account

Actual Result (gifs and screenshots are welcome!):
Screen switches from Brave to Chrome with send page for wrong email account and no way to select another email account

Expected result:
Want to stay on Brave and get to gmail account or have choice of accounts to use to send email

Reproduces how often:
every time, but just started happening about a week ago

Operating System and Brave Version(See the About Brave page in the main menu):
MacOS Big Sur Version 11.4
Version 1.26.74 Chromium: 91.0.4472.124 (Official Build) (x86_64)

Additional Information:

Hey @ksutherland !

Can you try updating your brave version to see if that fixes your issue?

Thank you


Can you also try disabling any extensions you have installed to see if that fixes the issue?

I would also refer to this page → and check to make sure those settings are not active in Chrome.


Hooray. The link you sent gave directions to find the well hidden method of changing the default email for chrome. (Why they don’t make this more obvious or even allow one to find it via search is beyond me.) Anyway your suggestion allowed me to fix the problem and I am very grateful. Below is an earlier message I had sent to you which didn’t go through because I used a different email address to try to send it to you.

Again, my thanks and all best wishes,



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.