Strict Site Isolation Mode breaks Embedded Media Video Playback

bug

#1

Issue

When strict isolation mode is enabled, embedded video or media playback is broken. Users are unable to interact with embedded video or media (they will see a player, but will be unable to click on the play button, etc.).

Reproduction

I have tested this with two embedded players: a SoundCloud embed and a Vimeo embed.

The SoundCloud embed is here (the O’Reilly Podcast with Brendan): https://www.oreilly.com/ideas/the-web-is-broken-lets-fix-it

The Vimeo embed is here (the recent tab improvement blog post): https://brave.com/new-brave-version-features-tab-improvements-for-enhanced-performance/

Reproduced both times reliably. When strict isolation mode is enabled, one cannot interact with the embedded players. When it is disabled, they work as intended.

Community Reports

I’ve seen this +1’ed on the BATProject subreddit, and potentially related issues here in Brave Community (e.g. with embedded players on Twitter).

Version Info

Brave 0.22.714
V8 6.6.346.26
rev fa2fbca
Muon 6.0.9
OS Release 17.5.0
Update Channel Release
OS Architecture x64
OS Platform macOS
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 66.0.3359.139

Imbedded videos don't play
Twitter videos and gifs won't play (audio can be heard, though)
#2

Hi @chriscat

Thanks for the great write up and examples. I believe you’re encountering this issue: https://github.com/brave/browser-laptop/issues/13716 - I’ve added your +1 to it.

Thanks for reporting!

Best,
Lauren


#3

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.