Strict fingerprinting blocking breaks Google Maps but no fingerprinting attempts are shown as blocked

Description of the issue:

Strict fingerprinting blocking breaks Google Maps but no fingerprinting attempts are shown as blocked.

How can this issue be reproduced?

  1. Set the default fingerprinting blocking setting to “strict” in browser settings.
  2. Visit https://www.google.com/maps/ .
  3. Note that the site is broken (the map itself loads but no other UI does).
  4. Check the Shields dropdown to see if anything was blocked.
  5. Note that the Shields dropdown shows 0 fingerprinting attempts blocked.
  6. Change fingerprinting blocking to “standard” (either globally or for that site).
  7. Note that the site loads properly.

Expected result:

With strict mode enabled, the Shields dropdown shows at least one fingerprinting attempt blocked (the one causing the page not to load properly).

Brave Version( check About Brave):

1.12.114

Additional Information:

I had strict mode enabled globally and for a while couldn’t tell what was breaking the page because the Shields dropdown didn’t show fingerprinting protection as blocking anything.

I see that there are related issues on GitHub and that the proposed solution is just to remove that portion of the UI:

Not having some indication in the Shields dropdown of whether the fingerprinting blocking setting is having an effect makes it more difficult for users to diagnose broken site issues like this.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.