Streak CRM won't import any data


Simply put, Streak CRM won’t import any data. The console is full of error messages as well.

TLDR: not currently usable in any way.

Happy to provide any needed details to debug!



Can you give a little bit more detail as to how far through the process you got?
I was able to install and use the extensions features (note that I didn’t try all the features, but emails seemed to be tracked and data was being populated where it needed to be).

In order to use the extension, however, you’ll need to set your Cookie Control setting in your Shields panel for gmail to Allow all cookies before Streak can access your data.


Sure, so let me tell you exactly the process I went through.

Install the plugin in Chrome, create a new pipeline, and add a box. The data will then be saved under that email address/Gmail account.

Install the plugin in Brave, and… nothing imports. None of the pipelines or data.

(I also have “Allow all cookies” set)


Okay I see.
I just tried to add a pipeline and I actually got an error message telling me that the “Pipeline cannot be found”. I’ll have to do some digging on this one.
Let me get back to you when I get some more info.
Appreciate your patience.


My pleasure, and please let me know if you need any further details. Really appreciate you looking into this. I’m trying to make a full switch to Brave, and unfortunately need this to run my business.


So here’s what I found:

Test method:

  1. Install Streak CRM
  2. Set up a couple pipelines with some data
  3. Save, then access Gmail from separate machine
  4. See if data is carried across sessions/accounts

Testing with Brave Release build (v0.56.15): :x:

  • Streak installed without issue after allowing cookies in Gmail domain
  • Extension works as intended until attempting to create a new Pipeline
    • Pipeline was created, but after checking in a new session or simply refreshing the page, an alert, Pipeline Cannot be found, sorry was displayed
  • Adjusting Shields/security settings did not seem to have an effect

Testing with Brave Beta (v0.56.7): :x:

  • Streak installed without issue after allowing cookies in Gmail domain
  • Extension all performs functions except for Pipelines. The Pipleine category in the side bar loaded continuously
    • Shields/security settings had no effect on this, even when Shields were down entirely:

Testing with Brave Developer build (v0.58.9): :white_check_mark:

  • Streak installed without issue after allowing cookies in Gmail domain
  • Extension works as intended, including pipeline creation and retrieval
  • I added three Pipeline “boxes” and was able to access them from a separate session on a different machine

I believe that the reason you’re seeing this is due to this issue we had, but was recently closed/resolved in the Developer build:

This leaves you with a couple options:

  1. You can download the Developer build of Brave (installs in parallel with other builds - that is, no Brave information you’ve previously saved will be overwritten, nor will anything be uninstalled.
    Note: Developer builds are early release and have not been through the appropriate testing phases yet. Dev builds are susceptible to crashes and other errors. That said, I use the Developer build very frequently and it performs without issue the majority of the time.
  2. Given the nature of the Developer version, this fix will hit Release (stable) build when its updated to the 0.57.x mark.

Hope this helps. Please let me know if you have any further questions.


Hi @Mattches,

Thanks for replying to the above post. I just downloaded Brave (Woo!) and am looking to also access Streak. I am currently on version 0.57 but no luck :sweat:. It seems as the same issue is occurring as last mentioned. Are you aware of when this update might be applied? If not I’ll go ahead and get down with the Dev :slight_smile:


This is labeled as 0.57.x release on GitHub. This means that, before Release hits v0.58.0 (or higher), the fix will be implemented. Release build currently sits at v0.57.18 and given the issue’s high priority, its likely you’ll see this addressed in the next update.

That said, you can download the Developer build now, and run it in parallel with the release version (or any Brave version) you’re using. Dev. build will install separately and will not overwrite any browsing or profile data saved in any other Brave version.


Sounds good! I’ll try that out until the next update. Thanks for the prompt reply :slight_smile:



I’m running ver 0.58.18, but I’m still getting the same issue - the pipelines won’t load, etc.

Warm Regards,


StreakCRM requires 3rd party cookies to be enabled in order to function. By default, Brave is configured to block 3p cookies.

  1. Open your Shields panel on the right-hand side of the address bar
  2. Change the cookie control setting in the panel to All Cookies Allowed
  3. The page will refresh and Streak should load and function as intended
    Your panel should look something like this:

Let me know if this resolves your issue.



Thank you for your note. I apologize if I wasn’t clear, but I already have allowed all cookies but it’s still not working:

Warm Regards,


Apologies, my mistake. However, I see your problem right there!

Have to allow device recognition for streak as well most likely - especially if its “syncing” or managing data across any device anchored to your Streak account.

Try allowing Device Recognition and let me know if that resolves the issue.


@Mattches, still no luck.


Hey @Mattches,

I’ve just updated to the new Brave browser (Version 0.58.18) with no luck running Streak. All my shields are down on Gmail but I still receive the same loading wheel as @brendanflorez. Is there any confirmation of the extension actually working in in Brave?

Thanks in advance.


So upon further inspection, I’m also unable to get StreamCRM up and running on Release channel. However, setting cookie control to Allow all in Beta or Dev versions and it works just fine. Its highly likely that this issue will be resolved in the next update to the browser, which shouldn’t be long from now.