Strange unwanted autocorrect in MacOS and iOS versions

Description of the issue:

When using Brave on certain websites, e.g. Facebook and Twitter, I get a very annoying popup whenever I type the letter ‘N’ to start a word. The popup offers to ‘correct’ it to the word ‘on’ and because of its position, this ‘correction’ often gets applied and then I have to backspace to delete it. See the attached image for an example.

This only happens on certain sites and not on others and I have only experienced it on my Apple devices, not on my Windows PC or Android tablet. The MacBook, iphone and ipad are all using the latest OS versions Brave versions.

The same problem is happening with Chrome on the same devices, but not with any other browser. It does not happen with any other letter or number. I have tried deleting and reinstalling Brave several times and restoring the factory defaults for Brave, but it makes no difference.

This problem only started happening in the past couple of months and I can’t pin it down to any particular OS release. I have looked for other threads mentioning the same problem, so I am baffled about what is going on.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

It’s pretty straightforward. Just type the letter “n” using Brave on an Apple device on Facebook or Twitter and see if you get the same popup.

Actual Result (gifs and screenshots are welcome!):

Expected result:

It shouldn’t be happening.

Reproduces how often:

Every time I type “n” on certain websites, such as FB or Twitter.

Operating System and Brave Version(See the About Brave page in the main menu):

MacOS Mojave 10.14.6,
Brave Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) (64-bit)

iOS 13.1.3 (iphone) iOS 12.4.2 (ipad mini 2)
Brave v 1.13

Additional Information:

Hi @evilcartman, welcome to community, and thanks a bunch for reporting this issue. On desktop, have you tried resolve by clearing your cookies?

Yes, I’ve tried that before. Not sure why that would also affect the iOS devices though.

Will try again and see if it makes a difference.

Hello again.

Nope, it hasn’t made a difference.

So I take it that this isn’t happening to anyone else at all?

In that case, where do I go from here? I have just updated to macOS Catalina 10.15.1 and restored default settings and cleared all caches yet again. Nothing has made a difference.

I may not have described the problem well in the title - it’s not an “autocorrect” as such, more of an annoying ‘helpful’ popup suggestion that gets in the way as illustrated in the attached image.

I am sure it is a bug rather than an issue with the machine, especially as it only happens to Brave and Chrome browsers on three different devices and no amount of factory restores clears it. I presume it’s an underlying issue within the underlying Chrome engine rather than it being Brave per se, so what is the best way of raising a ticket with the developers?