Stop the constant translation pop-up

On Nightly, we get pop-up notifications asking whether we want a site or language translated or not. As far as I understand, we can disable this, however, it doesn’t seem to apply for private tabs, so every English site I visit I get the pop-up even though I disabled translations for English:
27

Please make it so disabling translation for X language applies to all modes of Brave.

Thanks.