Stop (domain-)redirects

Description of the issue:
What’s up bois, this happens on a couple of websites, also with ads, but I’ll take archive.today as an example: when going to their main URL, it currently automatically redirects to archive.ph . Is there a way - and if not, could you create one - to stop that redirect from happening without my consent? I’d be happy with a Brave pop-up saying something like “archive.today wants to redirect you to archive.ph [decline] [allow]”

How can this issue be reproduced?

  1. visit archive.today
  2. find yourself on archive.ph
  3. ???
  4. you lose

Expected result:
find myself on archive.today

Brave Version( check About Brave):
Version 1.0.1 Chromium: 78.0.3904.108 (Offizieller Build) (64-Bit)

@BraveNew,
I don’t believe this option exists in Brave – in fact, in testing I didn’t see this option/feature in any browser. Chrome, Vivaldi, Firefox, Opera, Edge and Safari all redirect to archive.ph with no option to block/disallow the redirect.

I think your best option is to see if there’s an extension that will do it for you or to hit the Stop button real fast :stuck_out_tongue:

@Mattches
And do you not suppose this would be a sensible feature to have? Isn’t it somewhat of a security risk for websites to be able to just randomly send visitors to wherever without even asking? As mentioned in my OP, this is also a way in which some more shady websites regularly send users towards loads of ads (with the potential of malicious scripts being executed). Brave is still not blocking that and having this feature would automatically also prevent these ads.

Additionally, and the main reason why I bothered opening the topic, this problem I described 3 months ago still persists and the only solution is for me to visit the exact same page as before and then re-enable shields, as I described here:

So now I have a weird cookie-setting in Brave for archive.today but I cannot get rid of it because in order to do so, I’d have to visit archive.today and then disable shields but within milliseconds I’m being sent towards archive.ph.

What do?

@BraveNew,
Try the following:

  1. Go to brave://settings/content/cookies
  2. At the top, toggle the Clear cookies and site data when you quit Brave option “on”
  3. Add the domain of the cookie in question to the Clear on exit list here by either:
    • Clicking the “more options” menu, then Clear on exit
    • Clicking Add in the Clear on exit section and manually adding the appropriate domain to the list
  4. Quit the browser, then relaunch

Now check to see if the cookie remains.

@Mattches
As you’re likely short on time, you probably didn’t re-read the entire thread I linked. The list entries aren’t cookies but cookie-settings . Cookie-settings aren’t being deleted when closing the browser.
I found a way to get rid of all of them at once: I had to enable “content settings” for “delete on exit”. Now my entire list of content settings was nuked, as expected, so I’ll have to reconfigure all my settings, but at least I finally got rid of all the annoying entries for sites I can’t even browse to anymore. It is still quite annoying/buggy how this entire issue is handled by the browser. These entries shouldn’t even appear in that list and they also shouldn’t be “undeletable” manually.

The question still remains if the unauthorized auto-redirects aren’t a security risk. I’d imagine it wouldn’t be that hard to code the option for Brave to ask users whether they want to allow such a redirect or not. If none of the other browsers offer this, even better: another advantage Brave will have over them. You already introduced an “advanced” mode for shields, why not also have it for other settings so users have to enable this feature if they wish while boomers can keep being redirected without getting irritating questions about it from Brave.

@BraveNew,
Brave will alert you if you’re being redirected somewhere unsafe, as well as if you’re attempting to connect to a “lookalike” site (ie binance.com vs binace.com).